summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/dvxml/dvxml-0.1.7.ebuild')
-rw-r--r--dev-libs/dvxml/dvxml-0.1.7.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/dvxml/dvxml-0.1.7.ebuild b/dev-libs/dvxml/dvxml-0.1.7.ebuild
new file mode 100644
index 000000000000..579a9e3e21f3
--- /dev/null
+++ b/dev-libs/dvxml/dvxml-0.1.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dvxml/dvxml-0.1.7.ebuild,v 1.1 2008/02/01 04:49:00 halcy0n Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="dvxml provides some convenient stuff on top of the xmlwrapp package"
+SRC_URI="http://tinf2.vub.ac.be/~dvermeir/software/dv/${PN}/download/${P}.tar.gz"
+HOMEPAGE="http://tinf2.vub.ac.be/~dvermeir/software/dv/dvxml/html/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND="dev-libs/dvutil
+ >=dev-libs/xmlwrapp-0.5.0
+ dev-libs/libxslt
+ dev-libs/libxml2"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' Makefile.in || \
+ die "sed Makefile.in failed"
+
+ filter-ldflags -Wl,--as-needed
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog README AUTHORS
+ use doc && dohtml -r doc/html/*
+}