summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-imho')
-rw-r--r--dev-lisp/cl-imho/ChangeLog9
-rw-r--r--dev-lisp/cl-imho/Manifest6
-rw-r--r--dev-lisp/cl-imho/cl-imho-1.3.1-r1.ebuild45
-rw-r--r--dev-lisp/cl-imho/files/digest-cl-imho-1.3.1-r11
-rw-r--r--dev-lisp/cl-imho/metadata.xml8
5 files changed, 65 insertions, 4 deletions
diff --git a/dev-lisp/cl-imho/ChangeLog b/dev-lisp/cl-imho/ChangeLog
index 8f8d194ce81d..1d5059fdc249 100644
--- a/dev-lisp/cl-imho/ChangeLog
+++ b/dev-lisp/cl-imho/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/cl-imho
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-imho/ChangeLog,v 1.2 2003/10/16 04:56:37 mkennedy Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-imho/ChangeLog,v 1.3 2004/02/12 09:13:13 mkennedy Exp $
+
+*cl-imho-1.3.1-r1 (12 Feb 2004)
+
+ 12 Feb 2004; <mkennedy@gentoo.org> cl-imho-1.3.1-r1.ebuild, metadata.xml:
+ Cleanup for eclass changes.
15 Oct 2003; Matthew Kennedy <mkennedy@gentoo.org> cl-imho-1.3.1.ebuild,
metadata.xml:
diff --git a/dev-lisp/cl-imho/Manifest b/dev-lisp/cl-imho/Manifest
index 350a23bcf270..3fef477da6b4 100644
--- a/dev-lisp/cl-imho/Manifest
+++ b/dev-lisp/cl-imho/Manifest
@@ -1,4 +1,6 @@
-MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
-MD5 d3021c386da0bb2e43b2c4709f1e0d8e ChangeLog 451
+MD5 090a06688501c67a7c2332f8f9172a4b cl-imho-1.3.1-r1.ebuild 1356
MD5 4196a4ecf1b0e20d4892b6da2997ce77 cl-imho-1.3.1.ebuild 1782
+MD5 3c7f7651328a0d33bb1860975e161b6a ChangeLog 591
+MD5 337ea65f5bcb3144addf29bf5f6cac3c metadata.xml 570
MD5 72a5919bd9293a96f95f82d41dc02f0d files/digest-cl-imho-1.3.1 70
+MD5 72a5919bd9293a96f95f82d41dc02f0d files/digest-cl-imho-1.3.1-r1 70
diff --git a/dev-lisp/cl-imho/cl-imho-1.3.1-r1.ebuild b/dev-lisp/cl-imho/cl-imho-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..aeccf03fdc2b
--- /dev/null
+++ b/dev-lisp/cl-imho/cl-imho-1.3.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-imho/cl-imho-1.3.1-r1.ebuild,v 1.1 2004/02/12 09:13:13 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="IMHO is a toolkit that provides facilities for building highly interactive web applications"
+HOMEPAGE="http://freesw.onshored.com/wwwdist/imho/
+ http://alpha.onshored.com/lisp-software/"
+SRC_URI="http://alpha.onshored.com/debian/local/${PN}_${PV}.orig.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="dev-lisp/common-lisp-controller
+ dev-lisp/cl-odcl
+ =net-www/apache-1*"
+
+CLPACKAGE=imho
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ cd apache && make CFLAGS="${CFLAGS} -Wall -Wstrict-prototypes -fPIC" || die
+}
+
+src_install() {
+ exeinto /usr/lib/apache-extramodules
+ doexe apache/apache-1.3/mod_webapp.so
+
+ insinto /usr/include/webapplib
+ doins apache/webapplib/*.h
+ dolib.so apache/webapplib/libwebapp.so
+
+ dodoc apache/doc/*.txt
+ dodoc doc/*.txt doc/*.pdf
+ dohtml doc/*.html
+
+ insinto /usr/share/common-lisp/source/imho
+ doins *.lisp imho.asd imho.system
+ dodir /usr/share/common-lisp/systems
+ dosym /usr/share/common-lisp/source/imho/imho.asd \
+ /usr/share/common-lisp/systems/imho.asd
+ dosym /usr/share/common-lisp/source/imho/imho.system \
+ /usr/share/common-lisp/systems/imho.system
+}
diff --git a/dev-lisp/cl-imho/files/digest-cl-imho-1.3.1-r1 b/dev-lisp/cl-imho/files/digest-cl-imho-1.3.1-r1
new file mode 100644
index 000000000000..83ca572ebbf5
--- /dev/null
+++ b/dev-lisp/cl-imho/files/digest-cl-imho-1.3.1-r1
@@ -0,0 +1 @@
+MD5 2351f7c37608895a093f35f6a9c641fd cl-imho_1.3.1.orig.tar.gz 302657
diff --git a/dev-lisp/cl-imho/metadata.xml b/dev-lisp/cl-imho/metadata.xml
index f418045b09c8..dfec620555fa 100644
--- a/dev-lisp/cl-imho/metadata.xml
+++ b/dev-lisp/cl-imho/metadata.xml
@@ -2,4 +2,12 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>common-lisp</herd>
+<longdescription>
+IMHO is a toolkit that provides facilities for building highly
+interactive web applications, like WebCheckout. Some of the features
+that are in a useful state at this point are: session management,
+componentized document construction, template-based HTML rendering,
+and Java/Javascript integration. It is a loose functional equivalent
+of Apple's WebObjects framework."
+</longdescription>
</pkgmetadata>