summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/IPTables-libiptc/files/IPTables-libiptc-0.520.0-respect-cflags.patch')
-rw-r--r--dev-perl/IPTables-libiptc/files/IPTables-libiptc-0.520.0-respect-cflags.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-perl/IPTables-libiptc/files/IPTables-libiptc-0.520.0-respect-cflags.patch b/dev-perl/IPTables-libiptc/files/IPTables-libiptc-0.520.0-respect-cflags.patch
new file mode 100644
index 000000000000..9453e6623ad5
--- /dev/null
+++ b/dev-perl/IPTables-libiptc/files/IPTables-libiptc-0.520.0-respect-cflags.patch
@@ -0,0 +1,24 @@
+--- Makefile.PL.orig 2013-07-10 19:31:29.355162000 +0400
++++ Makefile.PL 2013-07-10 19:32:28.497557436 +0400
+@@ -256,7 +256,7 @@
+ LDDLFLAGS => '-shared -L$(PREFIX)/lib',
+ ## LDDLFLAGS => '-shared $(LOCAL_LIB_IPTC) -L$(PREFIX)/lib',
+ LDFLAGS => '-L$(PREFIX)/lib',
+- DEFINE => '-g -DIPTABLES_VERSION=\"$(IPTABLES_VERSION)\" -DXTABLES_LIBDIR=\"\$(XTABLES_LIBDIR)\" -DIPTABLES_VERSION_CODE=\$(IPTABLES_VERSION_CODE)',
++ DEFINE => '$(CFLAGS) -DIPTABLES_VERSION=\"$(IPTABLES_VERSION)\" -DXTABLES_LIBDIR=\"\$(XTABLES_LIBDIR)\" -DIPTABLES_VERSION_CODE=\$(IPTABLES_VERSION_CODE)',
+ # e.g., '-DHAVE_SOMETHING'
+ INC => '-I/usr/local/include -I./include -I.',
+ # e.g., '-I. -I/usr/include/other'
+
+--- iptables/Makefile.orig 2013-07-10 19:37:00.298563274 +0400
++++ iptables/Makefile 2013-07-10 19:37:16.786563628 +0400
+@@ -46,8 +46,7 @@
+ endif
+ LDLIBS=-ldl $(EXTRALIBS)
+
+-COPT_FLAGS:=-O2
+-CFLAGS:=$(COPT_FLAGS) -Wall -Wunused -I$(KERNEL_DIR)/include -I$(INCDIR) -I../include/ -fPIC -DXTABLES_INTERNAL -g
++CFLAGS+=-Wall -Wunused -I$(KERNEL_DIR)/include -I$(INCDIR) -I../include/ -fPIC -DXTABLES_INTERNAL
+ #-g -DDEBUG #-pg # -DIPTC_DEBUG
+
+ DEFINES:=-DIPTABLES_VERSION=\"$(IPTABLES_VERSION)\" -DXTABLES_LIBDIR=\"$(XTABLES_LIBDIR)\" -DIPTABLES_VERSION_CODE=\$(IPTABLES_VERSION_CODE)