summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/namespace-clean')
-rw-r--r--dev-perl/namespace-clean/ChangeLog8
-rw-r--r--dev-perl/namespace-clean/namespace-clean-0.14.ebuild22
2 files changed, 29 insertions, 1 deletions
diff --git a/dev-perl/namespace-clean/ChangeLog b/dev-perl/namespace-clean/ChangeLog
index 014c4ca5455e..3f81ee65fd28 100644
--- a/dev-perl/namespace-clean/ChangeLog
+++ b/dev-perl/namespace-clean/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/namespace-clean
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/namespace-clean/ChangeLog,v 1.6 2010/03/17 09:52:20 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/namespace-clean/ChangeLog,v 1.7 2010/03/19 06:52:46 tove Exp $
+
+*namespace-clean-0.14 (19 Mar 2010)
+
+ 19 Mar 2010; Torsten Veller <tove@gentoo.org>
+ +namespace-clean-0.14.ebuild:
+ Version bump
17 Mar 2010; Torsten Veller <tove@gentoo.org>
-namespace-clean-0.11.ebuild:
diff --git a/dev-perl/namespace-clean/namespace-clean-0.14.ebuild b/dev-perl/namespace-clean/namespace-clean-0.14.ebuild
new file mode 100644
index 000000000000..c654bfa8c9be
--- /dev/null
+++ b/dev-perl/namespace-clean/namespace-clean-0.14.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/namespace-clean/namespace-clean-0.14.ebuild,v 1.1 2010/03/19 06:52:46 tove Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=FLORA
+inherit perl-module
+
+DESCRIPTION="Keep imports and functions out of your namespace"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-perl/Sub-Identify-0.04
+ >=dev-perl/Sub-Name-0.04
+ >=dev-perl/B-Hooks-EndOfScope-0.07"
+DEPEND="${RDEPEND}
+ test? ( >=virtual/perl-Test-Simple-0.88 )"
+
+SRC_TEST=do