summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-PEAR/ChangeLog8
-rw-r--r--dev-php/PEAR-PEAR/PEAR-PEAR-1.4.9-r2.ebuild133
-rw-r--r--dev-php/PEAR-PEAR/files/digest-PEAR-PEAR-1.4.9-r212
3 files changed, 152 insertions, 1 deletions
diff --git a/dev-php/PEAR-PEAR/ChangeLog b/dev-php/PEAR-PEAR/ChangeLog
index 373f46964929..efa3f625b10a 100644
--- a/dev-php/PEAR-PEAR/ChangeLog
+++ b/dev-php/PEAR-PEAR/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/PEAR-PEAR
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/ChangeLog,v 1.67 2006/07/07 12:18:31 yoswink Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/ChangeLog,v 1.68 2006/07/12 05:56:38 sebastian Exp $
+
+*PEAR-PEAR-1.4.9-r2 (12 Jul 2006)
+
+ 12 Jul 2006; Sebastian Bergmann <sebastian@gentoo.org>
+ +PEAR-PEAR-1.4.9-r2.ebuild:
+ XML_RPC 1.5.0.
07 Jul 2006; Jose Luis Rivero <yoswink@gentoo.org>
PEAR-PEAR-1.4.9-r1.ebuild:
diff --git a/dev-php/PEAR-PEAR/PEAR-PEAR-1.4.9-r2.ebuild b/dev-php/PEAR-PEAR/PEAR-PEAR-1.4.9-r2.ebuild
new file mode 100644
index 000000000000..a9d6c6dd091e
--- /dev/null
+++ b/dev-php/PEAR-PEAR/PEAR-PEAR-1.4.9-r2.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/PEAR-PEAR-1.4.9-r2.ebuild,v 1.1 2006/07/12 05:56:38 sebastian Exp $
+
+inherit depend.php
+
+ARCHIVE_TAR="1.3.1"
+CONSOLE_GETOPT="1.2"
+PEAR="1.4.9"
+XML_RPC="1.5.0"
+
+[ -z "${PEAR_CACHEDIR}" ] && PEAR_CACHEDIR="/tmp/pear/cache"
+
+DESCRIPTION="PEAR Base System (PEAR, Archive_Tar, Console_Getopt, XML_RPC)."
+HOMEPAGE="http://pear.php.net/"
+SRC_URI="http://pear.php.net/get/Archive_Tar-${ARCHIVE_TAR}.tgz
+ http://pear.php.net/get/Console_Getopt-${CONSOLE_GETOPT}.tgz
+ http://pear.php.net/get/XML_RPC-${XML_RPC}.tgz
+ http://pear.php.net/get/PEAR-${PEAR}.tgz"
+
+LICENSE="PHP"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+# we deliberately force people to remove their old PEAR installations,
+# and any package which may have put an old-style PEAR installation onto
+# the box
+
+DEPEND="dev-lang/php
+ !dev-php/php
+ !dev-php/php-cgi
+ !dev-php/mod_php
+ !<dev-php/PEAR-PEAR-1.3.6-r2
+ !dev-php/PEAR-Archive_Tar
+ !dev-php/PEAR-Console_Getopt
+ !dev-php/PEAR-XML_RPC"
+
+pkg_setup() {
+ # we call this here, to ensure that the eclass picks the right
+ # version of php for the job
+ require_php_cli
+
+ # we check that PHP was compiled with the correct USE flags
+ if [[ ${PHP_VERSION} == "4" ]] ; then
+ require_php_with_use cli pcre expat zlib
+ else
+ require_php_with_use cli pcre xml zlib
+ fi
+}
+
+src_install() {
+ require_php_cli
+
+ # Prevent SNMP related sandbox violoation.
+ addpredict /usr/share/snmp/mibs/.index
+ addpredict /var/lib/net-snmp/
+
+ mkdir -p "${WORKDIR}/PEAR/XML/RPC"
+
+ # Install PEAR Package.
+ cp -r "${WORKDIR}/PEAR-${PEAR}/OS" "${WORKDIR}/PEAR/"
+ cp -r "${WORKDIR}/PEAR-${PEAR}/PEAR" "${WORKDIR}/PEAR/"
+ cp "${WORKDIR}/PEAR-${PEAR}/PEAR.php" "${WORKDIR}/PEAR/PEAR.php"
+ cp "${WORKDIR}/PEAR-${PEAR}/System.php" "${WORKDIR}/PEAR/System.php"
+
+ # Prepare /usr/bin/pear script.
+ cp "${WORKDIR}/PEAR-${PEAR}/scripts/pearcmd.php" "${WORKDIR}/PEAR/pearcmd.php"
+ sed -i "s:@pear_version@:${PEAR}:g" "${WORKDIR}/PEAR/pearcmd.php"
+ cp "${WORKDIR}/PEAR-${PEAR}/scripts/pear.sh" "${WORKDIR}/PEAR/pear"
+ sed -i "s:@php_bin@:${PHPCLI}:g" "${WORKDIR}/PEAR/pear" || die
+ sed -i "s:@bin_dir@:/usr/bin:g" "${WORKDIR}/PEAR/pear" || die
+ sed -i "s:@php_dir@:/usr/share/php:g" "${WORKDIR}/PEAR/pear" || die
+ sed -i "s:-d output_buffering=1:-d output_buffering=1 -d memory_limit=16M:g" "${WORKDIR}/PEAR/pear" || die
+
+ # Prepare /usr/bin/peardev script.
+ cp "${WORKDIR}/PEAR-${PEAR}/scripts/peardev.sh" "${WORKDIR}/PEAR/peardev"
+ sed -i "s:@php_bin@:${PHPCLI}:g" "${WORKDIR}/PEAR/peardev" || die
+ sed -i "s:@bin_dir@:/usr/bin:g" "${WORKDIR}/PEAR/peardev" || die
+ sed -i "s:@php_dir@:/usr/share/php:g" "${WORKDIR}/PEAR/peardev" || die
+
+ # Prepare /usr/bin/pecl script.
+ cp "${WORKDIR}/PEAR-${PEAR}/scripts/peclcmd.php" "${WORKDIR}/PEAR/peclcmd.php"
+ cp "${WORKDIR}/PEAR-${PEAR}/scripts/pecl.sh" "${WORKDIR}/PEAR/pecl"
+ sed -i "s:@php_bin@:${PHPCLI}:g" "${WORKDIR}/PEAR/pecl" || die
+ sed -i "s:@bin_dir@:/usr/bin:g" "${WORKDIR}/PEAR/pecl" || die
+ sed -i "s:@php_dir@:/usr/share/php:g" "${WORKDIR}/PEAR/pecl" || die
+
+ # Prepare PEAR/Dependency2.php.
+ sed -i "s:@PEAR-VER@:${PEAR}:g" "${WORKDIR}/PEAR/PEAR/Dependency2.php" || die
+
+ # Install Archive_Tar Package.
+ cp -r "${WORKDIR}/Archive_Tar-${ARCHIVE_TAR}/Archive" "${WORKDIR}/PEAR/Archive"
+
+ # Install Console_Getopt Package.
+ cp -r "${WORKDIR}/Console_Getopt-${CONSOLE_GETOPT}/Console" "${WORKDIR}/PEAR/"
+
+ # Install XML_RPC Package.
+ cp "${WORKDIR}/XML_RPC-${XML_RPC}/RPC.php" "${WORKDIR}/PEAR/XML/RPC.php"
+ cp "${WORKDIR}/XML_RPC-${XML_RPC}/Server.php" "${WORKDIR}/PEAR/XML/RPC/Server.php"
+
+ # Finalize installation.
+ cd "${WORKDIR}/PEAR"
+ insinto /usr/share/php
+ doins -r Archive Console OS PEAR XML *.php
+ dobin pear peardev pecl
+
+ insinto /etc
+ doins "${FILESDIR}/pear.conf"
+ sed -e "s|s:SUBSTLEN:\"SUBSTITUTEME\"|s:${#PHPCLI}:\"${PHPCLI}\"|g" -i "${D}/etc/pear.conf"
+
+ keepdir "${PEAR_CACHEDIR}"
+ fperms 755 "${PEAR_CACHEDIR}"
+}
+
+pkg_preinst() {
+ rm -f "${ROOT}/etc/pear.conf"
+}
+
+pkg_postinst() {
+ if has_version "<${PV}" ; then
+ ewarn "The location of the local PEAR repository has been changed"
+ ewarn "from /usr/lib/php to /usr/share/php."
+ fi
+
+ # Update PEAR channels as needed, add new ones to the list if needed
+ pearchans="pear.php.net pecl.php.net components.ez.no pear.phpdb.org pear.phing.info pear.symfony-project.com"
+
+ for chan in ${pearchans} ; do
+ pear channel-discover ${chan}
+ pear channel-update ${chan}
+ done
+}
diff --git a/dev-php/PEAR-PEAR/files/digest-PEAR-PEAR-1.4.9-r2 b/dev-php/PEAR-PEAR/files/digest-PEAR-PEAR-1.4.9-r2
new file mode 100644
index 000000000000..be5bf36dda5b
--- /dev/null
+++ b/dev-php/PEAR-PEAR/files/digest-PEAR-PEAR-1.4.9-r2
@@ -0,0 +1,12 @@
+MD5 31e54ce401302065d43888223a0be4d9 Archive_Tar-1.3.1.tgz 15102
+RMD160 e4d94299018d49835c9adb5d0d0bb7a4f3ee7fac Archive_Tar-1.3.1.tgz 15102
+SHA256 f128b58b249d4f182bdf846c6762462468dbfda045ccb332858e62934d655bf6 Archive_Tar-1.3.1.tgz 15102
+MD5 8f9ec8253c04350bc01ee7ca941e24b6 Console_Getopt-1.2.tgz 3370
+RMD160 d9bebe03b52a59b35a4d0fd0825da069037aa000 Console_Getopt-1.2.tgz 3370
+SHA256 90bc64b35832af79625ccd7a1cd981ae26adbe58e1296a052cc3947d9c959e0c Console_Getopt-1.2.tgz 3370
+MD5 52257e23987717c474a3da87f161a272 PEAR-1.4.9.tgz 283443
+RMD160 038fb6f0f5d22bb1bb34fff1f80cf609d434cdd2 PEAR-1.4.9.tgz 283443
+SHA256 41281d20e988018ae9a849d6f78ae111825e95432926dcfe17b27203e08567e1 PEAR-1.4.9.tgz 283443
+MD5 9f9205d8c8b3ca07a50c5d332c6fb722 XML_RPC-1.5.0.tgz 31619
+RMD160 866d2edcb68d6bb400d5a0364852ac62e267a3c4 XML_RPC-1.5.0.tgz 31619
+SHA256 d1e42d0e11a649cd0ca5cd3bbb3ced2f0984cdcde263d9c45ce6737405258edf XML_RPC-1.5.0.tgz 31619