summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/falcon')
-rw-r--r--dev-python/falcon/ChangeLog8
-rw-r--r--dev-python/falcon/falcon-0.1.7.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/falcon/ChangeLog b/dev-python/falcon/ChangeLog
index cf646156b668..74d509dd09d2 100644
--- a/dev-python/falcon/ChangeLog
+++ b/dev-python/falcon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/falcon
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/falcon/ChangeLog,v 1.3 2013/06/08 15:10:17 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/falcon/ChangeLog,v 1.4 2013/10/06 01:08:03 rafaelmartins Exp $
+
+*falcon-0.1.7 (06 Oct 2013)
+
+ 06 Oct 2013; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +falcon-0.1.7.ebuild:
+ Version bump.
08 Jun 2013; Ian Delaney <idella4@gentoo.org> falcon-0.1.6.ebuild:
pypy support added, deps adjusted accordingly
diff --git a/dev-python/falcon/falcon-0.1.7.ebuild b/dev-python/falcon/falcon-0.1.7.ebuild
new file mode 100644
index 000000000000..2ab7a4c3541b
--- /dev/null
+++ b/dev-python/falcon/falcon-0.1.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/falcon/falcon-0.1.7.ebuild,v 1.1 2013/10/06 01:08:03 rafaelmartins Exp $
+
+EAPI=5
+
+# Python 2.6 is supported, but depends on ordereddict, which has been in
+# improvise for months and is a minimal package. If needed
+# please let me know. PyPy also works
+PYTHON_COMPAT=( python{2_7,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="A supersonic micro-framework for building cloud APIs."
+HOMEPAGE="http://falconframework.org/ https://pypi.python.org/pypi/falcon"
+SRC_URI="https://github.com/racker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cython test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ cython? (
+ dev-python/cython[$(python_gen_usedep python{2_7,3_3})] )"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/cython[$(python_gen_usedep python{2_7,3_3})]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
+
+src_prepare() {
+ if ! use cython; then
+ sed -i -e 's/if with_cython:/if False:/' setup.py \
+ || die 'sed failed.'
+ fi
+}