summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygsl/pygsl-0.9.4.ebuild')
-rw-r--r--dev-python/pygsl/pygsl-0.9.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pygsl/pygsl-0.9.4.ebuild b/dev-python/pygsl/pygsl-0.9.4.ebuild
new file mode 100644
index 000000000000..46062e938070
--- /dev/null
+++ b/dev-python/pygsl/pygsl-0.9.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygsl/pygsl-0.9.4.ebuild,v 1.1 2009/03/04 19:34:38 bicatali Exp $
+
+inherit distutils
+
+DESCRIPTION="A Python interface for the GNU scientific library (gsl)."
+HOMEPAGE="http://pygsl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="examples"
+
+DEPEND="sci-libs/gsl
+ dev-python/numpy"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ cd "${S}/tests"
+ PYTHONPATH=$(ls -d ../build/lib*) "${python}" run_test.py || die "tests failed"
+}
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "install examples failed"
+ fi
+}