summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ascii85')
-rw-r--r--dev-ruby/ascii85/ChangeLog7
-rw-r--r--dev-ruby/ascii85/ascii85-1.0.2.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-ruby/ascii85/ChangeLog b/dev-ruby/ascii85/ChangeLog
index 612be5dd1eab..3c5853bd90d9 100644
--- a/dev-ruby/ascii85/ChangeLog
+++ b/dev-ruby/ascii85/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ascii85
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ascii85/ChangeLog,v 1.16 2012/10/28 17:46:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ascii85/ChangeLog,v 1.17 2012/11/07 07:02:04 graaff Exp $
+
+*ascii85-1.0.2 (07 Nov 2012)
+
+ 07 Nov 2012; Hans de Graaff <graaff@gentoo.org> +ascii85-1.0.2.ebuild:
+ Version bump with test fixes by Michel Boaventura in the ruby overlay.
28 Oct 2012; Raúl Porcel <armin76@gentoo.org> ascii85-1.0.1.ebuild:
Add ~alpha/~ia64/~sparc wrt #431384
diff --git a/dev-ruby/ascii85/ascii85-1.0.2.ebuild b/dev-ruby/ascii85/ascii85-1.0.2.ebuild
new file mode 100644
index 000000000000..a94050e61d42
--- /dev/null
+++ b/dev-ruby/ascii85/ascii85-1.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ascii85/ascii85-1.0.2.ebuild,v 1.1 2012/11/07 07:02:05 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.txt"
+
+RUBY_FAKEGEM_NAME="Ascii85"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Methods for encoding/decoding Adobe's binary-to-text encoding of the same name."
+HOMEPAGE="http://ascii85.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+}