summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rspec-mocks')
-rw-r--r--dev-ruby/rspec-mocks/ChangeLog7
-rw-r--r--dev-ruby/rspec-mocks/rspec-mocks-2.10.1.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-ruby/rspec-mocks/ChangeLog b/dev-ruby/rspec-mocks/ChangeLog
index 21eee32d2aba..404271038cc1 100644
--- a/dev-ruby/rspec-mocks/ChangeLog
+++ b/dev-ruby/rspec-mocks/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rspec-mocks
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/ChangeLog,v 1.23 2012/05/06 15:15:41 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/ChangeLog,v 1.24 2012/06/10 06:51:41 graaff Exp $
+
+*rspec-mocks-2.10.1 (10 Jun 2012)
+
+ 10 Jun 2012; Hans de Graaff <graaff@gentoo.org> +rspec-mocks-2.10.1.ebuild:
+ Version bump. Drop x86 keyword, bug 417587.
06 May 2012; Kacper Kowalik <xarthisius@gentoo.org> rspec-mocks-2.6.0.ebuild:
ppc64 stable wrt #369573
diff --git a/dev-ruby/rspec-mocks/rspec-mocks-2.10.1.ebuild b/dev-ruby/rspec-mocks/rspec-mocks-2.10.1.ebuild
new file mode 100644
index 000000000000..ab619e0d6b66
--- /dev/null
+++ b/dev-ruby/rspec-mocks/rspec-mocks-2.10.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/rspec-mocks-2.10.1.ebuild,v 1.1 2012/06/10 06:51:41 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+SRC_URI="https://github.com/rspec/${PN}/tarball/v${PV} -> ${P}-git.tgz"
+RUBY_S="rspec-${PN}-*"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-core-2.10.0:2
+ dev-ruby/rspec-expectations:2
+ )"
+
+# Not clear yet to what extend we need those (now)
+# >=dev-ruby/cucumber-0.6.2
+# >=dev-ruby/aruba-0.1.1"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ # This particular failure is reported to be fixed in jruby 1.6.
+ ewarn "Tests disabled because they crash jruby."
+ ;;
+ *)
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -ryaml -S rspec spec || die
+ ;;
+ esac
+
+ # There are features but they require aruba which we don't have yet.
+}