summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/xpath/xpath-0.1.4.ebuild')
-rw-r--r--dev-ruby/xpath/xpath-0.1.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/xpath/xpath-0.1.4.ebuild b/dev-ruby/xpath/xpath-0.1.4.ebuild
new file mode 100644
index 000000000000..ca1b7b2107f2
--- /dev/null
+++ b/dev-ruby/xpath/xpath-0.1.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/xpath/xpath-0.1.4.ebuild,v 1.1 2011/05/18 14:10:09 graaff Exp $
+
+EAPI="4"
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="XPath is a Ruby DSL around a subset of XPath 1.0."
+HOMEPAGE="https://github.com/jnicklas/xpath"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/d' spec/spec_helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S rspec spec || die "Tests failed."
+}