summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/latex2rtf/latex2rtf-1.9.14.ebuild')
-rw-r--r--dev-tex/latex2rtf/latex2rtf-1.9.14.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-tex/latex2rtf/latex2rtf-1.9.14.ebuild b/dev-tex/latex2rtf/latex2rtf-1.9.14.ebuild
new file mode 100644
index 000000000000..c7d81ea516f4
--- /dev/null
+++ b/dev-tex/latex2rtf/latex2rtf-1.9.14.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/latex2rtf/latex2rtf-1.9.14.ebuild,v 1.1 2004/02/26 19:05:41 usata Exp $
+
+IUSE="doc"
+
+DESCRIPTION="LaTeX to RTF converter"
+HOMEPAGE="http://latex2rtf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/latex2rtf/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ virtual/tetex
+ media-gfx/imagemagick"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-Makefile-gentoo.diff
+}
+
+src_compile() {
+ emake CC=${CC} || die
+}
+
+src_install() {
+ dodir /usr/share/doc/latex2rtf
+ PREFIX=${D}/usr make -e install || die
+ dodoc README doc/latex2rtf.txt
+ # if doc is not used, only the text version is intalled.
+ if use doc; then
+ dodoc doc/latex2rtf.html doc/latex2rtf.pdf doc/latex2rtf.txt
+ doinfo doc/latex2rtf.info
+ fi
+}