summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/catalyst')
-rw-r--r--dev-util/catalyst/ChangeLog10
-rw-r--r--dev-util/catalyst/catalyst-2.0.3.ebuild (renamed from dev-util/catalyst/catalyst-2.0.3_pre1.ebuild)29
-rw-r--r--dev-util/catalyst/catalyst-2.0.3_pre2.ebuild76
-rw-r--r--dev-util/catalyst/catalyst-2.0.3_pre3.ebuild76
-rw-r--r--dev-util/catalyst/files/digest-catalyst-2.0.33
-rw-r--r--dev-util/catalyst/files/digest-catalyst-2.0.3_pre13
-rw-r--r--dev-util/catalyst/files/digest-catalyst-2.0.3_pre23
-rw-r--r--dev-util/catalyst/files/digest-catalyst-2.0.3_pre33
8 files changed, 26 insertions, 177 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index 9a2177a8fbc8..4918aebcfdb9 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/catalyst
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.164 2007/03/06 19:25:40 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.165 2007/03/20 17:19:57 wolf31o2 Exp $
+
+*catalyst-2.0.3 (20 Mar 2007)
+
+ 20 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org>
+ -catalyst-2.0.3_pre1.ebuild, -catalyst-2.0.3_pre2.ebuild,
+ -catalyst-2.0.3_pre3.ebuild, +catalyst-2.0.3.ebuild:
+ Version bump to 2.0.3 to resolve bug #166294, bug #166420, bug #166426, bug
+ #166695, bug #169363, and bug #171157.
*catalyst-2.0.3_pre3 (06 Mar 2007)
diff --git a/dev-util/catalyst/catalyst-2.0.3_pre1.ebuild b/dev-util/catalyst/catalyst-2.0.3.ebuild
index d588dac69acd..f8aa2fbe7cb0 100644
--- a/dev-util/catalyst/catalyst-2.0.3_pre1.ebuild
+++ b/dev-util/catalyst/catalyst-2.0.3.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.3_pre1.ebuild,v 1.2 2007/03/05 03:25:22 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.3.ebuild,v 1.1 2007/03/20 17:19:57 wolf31o2 Exp $
inherit eutils
DESCRIPTION="Gentoo Linux official release metatool"
HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst"
-SRC_URI="http://dev.gentoo.org/~wolf31o2/${P}.tar.bz2"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~wolf31o2/sources/catalyst/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
@@ -16,14 +17,12 @@ IUSE="ccache cdr"
DEPEND=""
RDEPEND="dev-lang/python
app-crypt/shash
+ virtual/cdrtools
+ ccache? ( dev-util/ccache )
amd64? ( sys-apps/setarch )
+ ia64? ( sys-fs/dosfstools )
ppc64? ( sys-apps/setarch )
- ccache? ( dev-util/ccache )
- cdr? (
- virtual/cdrtools
- ia64? ( sys-fs/dosfstools )
- app-misc/zisofs-tools
- >=sys-fs/squashfs-tools-2.1 )"
+ !x86-fbsd? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
pkg_setup() {
if use ccache ; then
@@ -34,10 +33,10 @@ pkg_setup() {
ewarn "then you should add ccache to your USE."
fi
echo
- elog "The template spec files are now installed by default. You can find"
- elog "them under /usr/share/doc/${PF}/examples"
- elog "and they are considered to be the authorative source of information"
- elog "on catalyst."
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
}
src_install() {
@@ -69,8 +68,8 @@ src_install() {
}
pkg_postinst() {
- elog "You can find more information about catalyst by checking out the"
- elog "catalyst project page at:"
- elog "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
echo
}
diff --git a/dev-util/catalyst/catalyst-2.0.3_pre2.ebuild b/dev-util/catalyst/catalyst-2.0.3_pre2.ebuild
deleted file mode 100644
index d27c5127eccd..000000000000
--- a/dev-util/catalyst/catalyst-2.0.3_pre2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.3_pre2.ebuild,v 1.2 2007/03/05 03:25:22 genone Exp $
-
-inherit eutils
-
-DESCRIPTION="Gentoo Linux official release metatool"
-HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst"
-SRC_URI="http://dev.gentoo.org/~wolf31o2/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="ccache cdr"
-
-DEPEND=""
-RDEPEND="dev-lang/python
- app-crypt/shash
- amd64? ( sys-apps/setarch )
- ppc64? ( sys-apps/setarch )
- ccache? ( dev-util/ccache )
- cdr? (
- virtual/cdrtools
- ia64? ( sys-fs/dosfstools )
- app-misc/zisofs-tools
- >=sys-fs/squashfs-tools-2.1 )"
-
-pkg_setup() {
- if use ccache ; then
- einfo "Enabling ccache support for catalyst."
- else
- ewarn "By default, ccache support for catalyst is disabled."
- ewarn "If this is not what you intended,"
- ewarn "then you should add ccache to your USE."
- fi
- echo
- elog "The template spec files are now installed by default. You can find"
- elog "them under /usr/share/doc/${PF}/examples"
- elog "and they are considered to be the authorative source of information"
- elog "on catalyst."
-}
-
-src_install() {
- insinto /usr/lib/${PN}/arch
- doins arch/* || die "copying arch/*"
- insinto /usr/lib/${PN}/modules
- doins modules/* || die "copying modules/*"
- insinto /usr/lib/${PN}/livecd/cdtar
- doins livecd/cdtar/* || die "copying cdtar/*"
- insinto /usr/lib/${PN}/livecd/files
- doins livecd/files/* || die "copying files/*"
- for x in targets/*; do
- exeinto /usr/lib/${PN}/$x
- doexe $x/* || die "copying ${x}"
- done
- exeinto /usr/lib/${PN}
- doexe catalyst || die "copying catalyst"
- dodir /usr/bin
- dosym /usr/lib/${PN}/catalyst /usr/bin/catalyst
- insinto /etc/catalyst
- doins files/catalyst.conf files/catalystrc || die "copying configuration"
- DOCDESTTREE="." dohtml -A spec,msg,example -r examples files
- dodoc README ChangeLog ChangeLog.old AUTHORS
- doman files/catalyst.1
- # Here is where we actually enable ccache
- use ccache && \
- dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
- /etc/catalyst/catalyst.conf
-}
-
-pkg_postinst() {
- elog "You can find more information about catalyst by checking out the"
- elog "catalyst project page at:"
- elog "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
- echo
-}
diff --git a/dev-util/catalyst/catalyst-2.0.3_pre3.ebuild b/dev-util/catalyst/catalyst-2.0.3_pre3.ebuild
deleted file mode 100644
index ca0bdf8e572f..000000000000
--- a/dev-util/catalyst/catalyst-2.0.3_pre3.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.3_pre3.ebuild,v 1.1 2007/03/06 19:25:40 wolf31o2 Exp $
-
-inherit eutils
-
-DESCRIPTION="Gentoo Linux official release metatool"
-HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst"
-SRC_URI="http://dev.gentoo.org/~wolf31o2/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="ccache cdr"
-
-DEPEND=""
-RDEPEND="dev-lang/python
- app-crypt/shash
- amd64? ( sys-apps/setarch )
- ppc64? ( sys-apps/setarch )
- ccache? ( dev-util/ccache )
- cdr? (
- virtual/cdrtools
- ia64? ( sys-fs/dosfstools )
- app-misc/zisofs-tools
- >=sys-fs/squashfs-tools-2.1 )"
-
-pkg_setup() {
- if use ccache ; then
- einfo "Enabling ccache support for catalyst."
- else
- ewarn "By default, ccache support for catalyst is disabled."
- ewarn "If this is not what you intended,"
- ewarn "then you should add ccache to your USE."
- fi
- echo
- elog "The template spec files are now installed by default. You can find"
- elog "them under /usr/share/doc/${PF}/examples"
- elog "and they are considered to be the authorative source of information"
- elog "on catalyst."
-}
-
-src_install() {
- insinto /usr/lib/${PN}/arch
- doins arch/* || die "copying arch/*"
- insinto /usr/lib/${PN}/modules
- doins modules/* || die "copying modules/*"
- insinto /usr/lib/${PN}/livecd/cdtar
- doins livecd/cdtar/* || die "copying cdtar/*"
- insinto /usr/lib/${PN}/livecd/files
- doins livecd/files/* || die "copying files/*"
- for x in targets/*; do
- exeinto /usr/lib/${PN}/$x
- doexe $x/* || die "copying ${x}"
- done
- exeinto /usr/lib/${PN}
- doexe catalyst || die "copying catalyst"
- dodir /usr/bin
- dosym /usr/lib/${PN}/catalyst /usr/bin/catalyst
- insinto /etc/catalyst
- doins files/catalyst.conf files/catalystrc || die "copying configuration"
- DOCDESTTREE="." dohtml -A spec,msg,example -r examples files
- dodoc README ChangeLog ChangeLog.old AUTHORS
- doman files/catalyst.1
- # Here is where we actually enable ccache
- use ccache && \
- dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
- /etc/catalyst/catalyst.conf
-}
-
-pkg_postinst() {
- elog "You can find more information about catalyst by checking out the"
- elog "catalyst project page at:"
- elog "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
- echo
-}
diff --git a/dev-util/catalyst/files/digest-catalyst-2.0.3 b/dev-util/catalyst/files/digest-catalyst-2.0.3
new file mode 100644
index 000000000000..5b5355f2a10d
--- /dev/null
+++ b/dev-util/catalyst/files/digest-catalyst-2.0.3
@@ -0,0 +1,3 @@
+MD5 274f5b89f6ea164bbd3ef99e8f034d12 catalyst-2.0.3.tar.bz2 783648
+RMD160 f59d8cb5e08464ebac8c3dbc7292903a4cc08812 catalyst-2.0.3.tar.bz2 783648
+SHA256 7355cb93f23071be80d10a5269b8f2a78edd9626cf4ad8f717a79139a4189ad5 catalyst-2.0.3.tar.bz2 783648
diff --git a/dev-util/catalyst/files/digest-catalyst-2.0.3_pre1 b/dev-util/catalyst/files/digest-catalyst-2.0.3_pre1
deleted file mode 100644
index 0be360f40472..000000000000
--- a/dev-util/catalyst/files/digest-catalyst-2.0.3_pre1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 47ea0f5920fa0ce37c1733ffeb8d995e catalyst-2.0.3_pre1.tar.bz2 783416
-RMD160 1ca91c5d73fd37750a11fb88ff93c43d22152e6b catalyst-2.0.3_pre1.tar.bz2 783416
-SHA256 5e9f9d4513ed9ecbcdf4099b629cf9960cdd92dada7876053861b3c91bcb690b catalyst-2.0.3_pre1.tar.bz2 783416
diff --git a/dev-util/catalyst/files/digest-catalyst-2.0.3_pre2 b/dev-util/catalyst/files/digest-catalyst-2.0.3_pre2
deleted file mode 100644
index 9ec148e5b8ad..000000000000
--- a/dev-util/catalyst/files/digest-catalyst-2.0.3_pre2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 3fee23ceccffc5e98fb6c39162c5b3fa catalyst-2.0.3_pre2.tar.bz2 783205
-RMD160 77fa1e09b4cae21611626a11c8da09c237ab9440 catalyst-2.0.3_pre2.tar.bz2 783205
-SHA256 481f1b04cb64930a2395d39fa67c9b0389e6ee1053c931428962ea7cbc4eeab7 catalyst-2.0.3_pre2.tar.bz2 783205
diff --git a/dev-util/catalyst/files/digest-catalyst-2.0.3_pre3 b/dev-util/catalyst/files/digest-catalyst-2.0.3_pre3
deleted file mode 100644
index 8dd31e84e8da..000000000000
--- a/dev-util/catalyst/files/digest-catalyst-2.0.3_pre3
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 ead55e988e5da610099f7e83fe9f1ec1 catalyst-2.0.3_pre3.tar.bz2 783672
-RMD160 9125a549d3804516fc261d7ebda62363ee624dcd catalyst-2.0.3_pre3.tar.bz2 783672
-SHA256 7fcdc5fc75f8cb0b4432de031d5c0c1c485db6afdd9e6ead25284685344a6b5b catalyst-2.0.3_pre3.tar.bz2 783672