summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/oprofile/oprofile-0.9.1-r1.ebuild')
-rw-r--r--dev-util/oprofile/oprofile-0.9.1-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-util/oprofile/oprofile-0.9.1-r1.ebuild b/dev-util/oprofile/oprofile-0.9.1-r1.ebuild
index e68398cbcd1d..8dceb820f407 100644
--- a/dev-util/oprofile/oprofile-0.9.1-r1.ebuild
+++ b/dev-util/oprofile/oprofile-0.9.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.1-r1.ebuild,v 1.11 2007/03/05 04:04:53 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.1-r1.ebuild,v 1.12 2007/04/16 15:15:00 spock Exp $
inherit eutils qt3 linux-info
@@ -69,7 +69,9 @@ src_install() {
}
pkg_postinst() {
- [[ ${ROOT} == / ]] && /sbin/modules-update
+ if [[ ${ROOT} == / ]] ; then
+ [[ -x /sbin/update-modules ]] && /sbin/update-modules || /sbin/modules-update
+ fi
echo
elog "Now load the oprofile module by running:"