summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/premake/premake-4.3.ebuild')
-rw-r--r--dev-util/premake/premake-4.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/premake/premake-4.3.ebuild b/dev-util/premake/premake-4.3.ebuild
new file mode 100644
index 000000000000..929d15d3744f
--- /dev/null
+++ b/dev-util/premake/premake-4.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/premake/premake-4.3.ebuild,v 1.1 2011/05/01 21:57:24 hwoarang Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="A makefile generation tool"
+HOMEPAGE="http://premake.berlios.de/"
+SRC_URI="mirror://sourceforge/premake/${P}-src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/archless.patch"
+}
+
+src_compile() {
+ cd "${S}/build/gmake.unix/"
+ emake
+}
+
+src_install() {
+ dobin bin/release/premake4 || die
+}