summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/rapidsvn/rapidsvn-0.9.3.ebuild')
-rw-r--r--dev-util/rapidsvn/rapidsvn-0.9.3.ebuild29
1 files changed, 19 insertions, 10 deletions
diff --git a/dev-util/rapidsvn/rapidsvn-0.9.3.ebuild b/dev-util/rapidsvn/rapidsvn-0.9.3.ebuild
index a7d0027032b6..7352350fc5bf 100644
--- a/dev-util/rapidsvn/rapidsvn-0.9.3.ebuild
+++ b/dev-util/rapidsvn/rapidsvn-0.9.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/rapidsvn/rapidsvn-0.9.3.ebuild,v 1.14 2007/06/26 02:04:52 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rapidsvn/rapidsvn-0.9.3.ebuild,v 1.15 2007/06/26 05:40:11 nerdboy Exp $
-inherit eutils libtool autotools wxwidgets
+inherit eutils libtool autotools wxwidgets flag-o-matic
DESCRIPTION="Cross-platform GUI front-end for the Subversion revision system."
HOMEPAGE="http://rapidsvn.tigris.org/"
@@ -15,22 +15,23 @@ IUSE="doc static"
DEPEND=">=dev-util/subversion-1.3.2-r1
>=net-misc/neon-0.26
>=x11-libs/wxGTK-2.6.2
- <dev-libs/apr-0.9.13
+ >=dev-libs/apr-0.9.7
+ >=dev-libs/apr-util-0.9.7
doc? ( dev-libs/libxslt
app-text/docbook-sgml-utils
app-doc/doxygen
app-text/docbook-xsl-stylesheets )"
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="latest"
-
src_unpack() {
unpack ${A}
cd ${S}
+
# Apparently we still the --as-needed link patch...
epatch ${FILESDIR}/${PN}-svncpp_link.patch || die "epatch failed"
+
+ export WANT_AUTOCONF=2.5
+ autoconf
elibtoolize
- eautoreconf
}
src_compile() {
@@ -43,12 +44,16 @@ src_compile() {
einfo "Found neon support; continuing..."
fi
- # if you compiled subversion without (the) apache2 (flag) and with the
+ # if you compiled subversion without (the) apache2 (flag) and with the
# berkdb flag, you will get an error that it can't find the lib db4
# Note: this should be fixed in rapidsvn 0.9.3 and later
local myconf
local xslss_dir
+ local apr_suffix=""
+ if has_version ">dev-libs/apr-util-1"; then
+ apr_suffix="-1"
+ fi
if use doc; then
xslss_dir=$(ls -1d /usr/share/sgml/docbook/xsl-stylesheets*|head -n1)
myconf="--with-docbook-xsl=$xslss_dir"
@@ -66,10 +71,13 @@ src_compile() {
need-wxwidgets gtk2
myconf="${myconf} --with-wx-config=${WX_CONFIG}"
+ append-flags $( /usr/bin/apr${apr_suffix}-config --cppflags )
+
econf --with-svn-lib=/usr/$(get_libdir) \
--with-svn-include=/usr/include \
--with-neon-config=/usr/bin/neon-config \
- --with-apr-config=/usr/bin/apr-config \
+ --with-apr-config="/usr/bin/apr${apr_suffix}-config" \
+ --with-apu-config="/usr/bin/apu${apr_suffix}-config" \
${myconf} || die "econf failed"
emake || die "emake failed"
}
@@ -78,7 +86,8 @@ src_install() {
einstall || die "einstall failed"
doman doc/manpage/rapidsvn.1 || die "doman failed"
doicon src/res/bitmaps/svn.xpm
- make_desktop_entry rapidsvn RapidSVN svn.xpm RevisionControl
+ make_desktop_entry rapidsvn "RapidSVN ${PV}" \
+ "/usr/share/pixmaps/svn.xpm"
dodoc HACKING.txt TRANSLATIONS
if use doc ; then
dodoc AUTHORS CHANGES NEWS README