summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/ChangeLog11
-rw-r--r--dev-vcs/git/git-1.7.2.5.ebuild6
-rw-r--r--dev-vcs/git/git-1.7.3.4-r1.ebuild6
-rw-r--r--dev-vcs/git/git-1.7.3.5-r1.ebuild6
-rw-r--r--dev-vcs/git/git-1.7.3.5-r2.ebuild6
-rw-r--r--dev-vcs/git/git-1.7.3.5.ebuild6
-rw-r--r--dev-vcs/git/git-1.7.4.1.ebuild6
-rw-r--r--dev-vcs/git/git-1.7.4.4.ebuild6
-rw-r--r--dev-vcs/git/git-1.7.4.5.ebuild6
-rw-r--r--dev-vcs/git/git-1.7.4.ebuild6
-rw-r--r--dev-vcs/git/git-1.7.5.3.ebuild6
-rw-r--r--dev-vcs/git/git-1.7.5_rc1.ebuild6
-rw-r--r--dev-vcs/git/git-1.7.5_rc3.ebuild6
-rw-r--r--dev-vcs/git/git-1.7.6.ebuild6
-rw-r--r--dev-vcs/git/git-9999.ebuild6
15 files changed, 24 insertions, 71 deletions
diff --git a/dev-vcs/git/ChangeLog b/dev-vcs/git/ChangeLog
index 4ce698696f3c..7ebeabaaeacf 100644
--- a/dev-vcs/git/ChangeLog
+++ b/dev-vcs/git/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-vcs/git
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.97 2011/07/13 07:03:15 mduft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.98 2011/08/19 18:43:47 darkside Exp $
+
+ 19 Aug 2011; Jeremy Olexa <darkside@gentoo.org> git-1.7.2.5.ebuild,
+ git-1.7.3.4-r1.ebuild, git-1.7.3.5.ebuild, git-1.7.3.5-r1.ebuild,
+ git-1.7.3.5-r2.ebuild, git-1.7.4.ebuild, git-1.7.4.1.ebuild,
+ git-1.7.4.4.ebuild, git-1.7.4.5.ebuild, git-1.7.5_rc1.ebuild,
+ git-1.7.5_rc3.ebuild, git-1.7.5.3.ebuild, git-1.7.6.ebuild, git-9999.ebuild:
+ Remove useless/redundant built_with_use check for subversion[perl] since the
+ addition of USE-deps. Signed off by maintainer. Tangentially related to bug
+ 250179
13 Jul 2011; Markus Duft <mduft@gentoo.org> git-1.7.6.ebuild,
+files/git-1.7.6-interix.patch:
diff --git a/dev-vcs/git/git-1.7.2.5.ebuild b/dev-vcs/git/git-1.7.2.5.ebuild
index 984fbb191aa1..1e7fa9b29936 100644
--- a/dev-vcs/git/git-1.7.2.5.ebuild
+++ b/dev-vcs/git/git-1.7.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.2.5.ebuild,v 1.12 2011/04/04 08:58:41 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.2.5.ebuild,v 1.13 2011/08/19 18:43:47 darkside Exp $
EAPI=3
@@ -457,10 +457,6 @@ showpkgdeps() {
pkg_postinst() {
use emacs && elisp-site-regen
- if use subversion && has_version dev-vcs/subversion && ! built_with_use --missing false dev-vcs/subversion perl ; then
- ewarn "You must build dev-vcs/subversion with USE=perl"
- ewarn "to get the full functionality of git-svn!"
- fi
elog "These additional scripts need some dependencies:"
echo
showpkgdeps git-quiltimport "dev-util/quilt"
diff --git a/dev-vcs/git/git-1.7.3.4-r1.ebuild b/dev-vcs/git/git-1.7.3.4-r1.ebuild
index 3d45213fd5d8..048177f5682a 100644
--- a/dev-vcs/git/git-1.7.3.4-r1.ebuild
+++ b/dev-vcs/git/git-1.7.3.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.3.4-r1.ebuild,v 1.16 2011/04/04 08:58:41 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.3.4-r1.ebuild,v 1.17 2011/08/19 18:43:47 darkside Exp $
EAPI=3
@@ -477,10 +477,6 @@ showpkgdeps() {
pkg_postinst() {
use emacs && elisp-site-regen
- if use subversion && has_version dev-vcs/subversion && ! built_with_use --missing false dev-vcs/subversion perl ; then
- ewarn "You must build dev-vcs/subversion with USE=perl"
- ewarn "to get the full functionality of git-svn!"
- fi
elog "These additional scripts need some dependencies:"
echo
showpkgdeps git-quiltimport "dev-util/quilt"
diff --git a/dev-vcs/git/git-1.7.3.5-r1.ebuild b/dev-vcs/git/git-1.7.3.5-r1.ebuild
index 925f6d10ceee..c70132b1c8e4 100644
--- a/dev-vcs/git/git-1.7.3.5-r1.ebuild
+++ b/dev-vcs/git/git-1.7.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.3.5-r1.ebuild,v 1.4 2011/04/04 08:58:41 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.3.5-r1.ebuild,v 1.5 2011/08/19 18:43:47 darkside Exp $
EAPI=3
@@ -484,10 +484,6 @@ showpkgdeps() {
pkg_postinst() {
use emacs && elisp-site-regen
- if use subversion && has_version dev-vcs/subversion && ! built_with_use --missing false dev-vcs/subversion perl ; then
- ewarn "You must build dev-vcs/subversion with USE=perl"
- ewarn "to get the full functionality of git-svn!"
- fi
elog "These additional scripts need some dependencies:"
echo
showpkgdeps git-quiltimport "dev-util/quilt"
diff --git a/dev-vcs/git/git-1.7.3.5-r2.ebuild b/dev-vcs/git/git-1.7.3.5-r2.ebuild
index 7c74fe655afd..f24b2953522f 100644
--- a/dev-vcs/git/git-1.7.3.5-r2.ebuild
+++ b/dev-vcs/git/git-1.7.3.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.3.5-r2.ebuild,v 1.6 2011/04/04 08:58:41 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.3.5-r2.ebuild,v 1.7 2011/08/19 18:43:47 darkside Exp $
EAPI=3
@@ -493,10 +493,6 @@ showpkgdeps() {
pkg_postinst() {
use emacs && elisp-site-regen
use python && python_mod_optimize git_remote_helpers
- if use subversion && has_version dev-vcs/subversion && ! built_with_use --missing false dev-vcs/subversion perl ; then
- ewarn "You must build dev-vcs/subversion with USE=perl"
- ewarn "to get the full functionality of git-svn!"
- fi
elog "These additional scripts need some dependencies:"
echo
showpkgdeps git-quiltimport "dev-util/quilt"
diff --git a/dev-vcs/git/git-1.7.3.5.ebuild b/dev-vcs/git/git-1.7.3.5.ebuild
index ed1c35be4b8f..25ec75829662 100644
--- a/dev-vcs/git/git-1.7.3.5.ebuild
+++ b/dev-vcs/git/git-1.7.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.3.5.ebuild,v 1.2 2011/04/04 08:58:41 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.3.5.ebuild,v 1.3 2011/08/19 18:43:47 darkside Exp $
EAPI=3
@@ -474,10 +474,6 @@ showpkgdeps() {
pkg_postinst() {
use emacs && elisp-site-regen
- if use subversion && has_version dev-vcs/subversion && ! built_with_use --missing false dev-vcs/subversion perl ; then
- ewarn "You must build dev-vcs/subversion with USE=perl"
- ewarn "to get the full functionality of git-svn!"
- fi
elog "These additional scripts need some dependencies:"
echo
showpkgdeps git-quiltimport "dev-util/quilt"
diff --git a/dev-vcs/git/git-1.7.4.1.ebuild b/dev-vcs/git/git-1.7.4.1.ebuild
index 98d05ca4d822..ef44e38f8fd6 100644
--- a/dev-vcs/git/git-1.7.4.1.ebuild
+++ b/dev-vcs/git/git-1.7.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.4.1.ebuild,v 1.2 2011/04/04 08:58:41 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.4.1.ebuild,v 1.3 2011/08/19 18:43:47 darkside Exp $
EAPI=3
@@ -497,10 +497,6 @@ showpkgdeps() {
pkg_postinst() {
use emacs && elisp-site-regen
use python && python_mod_optimize git_remote_helpers
- if use subversion && has_version dev-vcs/subversion && ! built_with_use --missing false dev-vcs/subversion perl ; then
- ewarn "You must build dev-vcs/subversion with USE=perl"
- ewarn "to get the full functionality of git-svn!"
- fi
elog "These additional scripts need some dependencies:"
echo
showpkgdeps git-quiltimport "dev-util/quilt"
diff --git a/dev-vcs/git/git-1.7.4.4.ebuild b/dev-vcs/git/git-1.7.4.4.ebuild
index b2ef60784665..e87d69df7c19 100644
--- a/dev-vcs/git/git-1.7.4.4.ebuild
+++ b/dev-vcs/git/git-1.7.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.4.4.ebuild,v 1.1 2011/04/06 23:07:49 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.4.4.ebuild,v 1.2 2011/08/19 18:43:47 darkside Exp $
EAPI=3
@@ -497,10 +497,6 @@ showpkgdeps() {
pkg_postinst() {
use emacs && elisp-site-regen
use python && python_mod_optimize git_remote_helpers
- if use subversion && has_version dev-vcs/subversion && ! built_with_use --missing false dev-vcs/subversion perl ; then
- ewarn "You must build dev-vcs/subversion with USE=perl"
- ewarn "to get the full functionality of git-svn!"
- fi
elog "These additional scripts need some dependencies:"
echo
showpkgdeps git-quiltimport "dev-util/quilt"
diff --git a/dev-vcs/git/git-1.7.4.5.ebuild b/dev-vcs/git/git-1.7.4.5.ebuild
index fd7f342769a2..efb8b55cb2f0 100644
--- a/dev-vcs/git/git-1.7.4.5.ebuild
+++ b/dev-vcs/git/git-1.7.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.4.5.ebuild,v 1.1 2011/04/27 05:27:36 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.4.5.ebuild,v 1.2 2011/08/19 18:43:47 darkside Exp $
EAPI=3
@@ -495,10 +495,6 @@ showpkgdeps() {
pkg_postinst() {
use emacs && elisp-site-regen
use python && python_mod_optimize git_remote_helpers
- if use subversion && has_version dev-vcs/subversion && ! built_with_use --missing false dev-vcs/subversion perl ; then
- ewarn "You must build dev-vcs/subversion with USE=perl"
- ewarn "to get the full functionality of git-svn!"
- fi
elog "These additional scripts need some dependencies:"
echo
showpkgdeps git-quiltimport "dev-util/quilt"
diff --git a/dev-vcs/git/git-1.7.4.ebuild b/dev-vcs/git/git-1.7.4.ebuild
index 7bcc0d3f1fa0..d3afb190cbe7 100644
--- a/dev-vcs/git/git-1.7.4.ebuild
+++ b/dev-vcs/git/git-1.7.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.4.ebuild,v 1.2 2011/04/04 08:58:41 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.4.ebuild,v 1.3 2011/08/19 18:43:47 darkside Exp $
EAPI=3
@@ -497,10 +497,6 @@ showpkgdeps() {
pkg_postinst() {
use emacs && elisp-site-regen
use python && python_mod_optimize git_remote_helpers
- if use subversion && has_version dev-vcs/subversion && ! built_with_use --missing false dev-vcs/subversion perl ; then
- ewarn "You must build dev-vcs/subversion with USE=perl"
- ewarn "to get the full functionality of git-svn!"
- fi
elog "These additional scripts need some dependencies:"
echo
showpkgdeps git-quiltimport "dev-util/quilt"
diff --git a/dev-vcs/git/git-1.7.5.3.ebuild b/dev-vcs/git/git-1.7.5.3.ebuild
index 7acc019da89e..29ffbae946b7 100644
--- a/dev-vcs/git/git-1.7.5.3.ebuild
+++ b/dev-vcs/git/git-1.7.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.5.3.ebuild,v 1.2 2011/05/31 06:27:02 mduft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.5.3.ebuild,v 1.3 2011/08/19 18:43:47 darkside Exp $
EAPI=3
@@ -499,10 +499,6 @@ showpkgdeps() {
pkg_postinst() {
use emacs && elisp-site-regen
use python && python_mod_optimize git_remote_helpers
- if use subversion && has_version dev-vcs/subversion && ! built_with_use --missing false dev-vcs/subversion perl ; then
- ewarn "You must build dev-vcs/subversion with USE=perl"
- ewarn "to get the full functionality of git-svn!"
- fi
elog "These additional scripts need some dependencies:"
echo
showpkgdeps git-quiltimport "dev-util/quilt"
diff --git a/dev-vcs/git/git-1.7.5_rc1.ebuild b/dev-vcs/git/git-1.7.5_rc1.ebuild
index 5b265010b966..95e8e5c6e366 100644
--- a/dev-vcs/git/git-1.7.5_rc1.ebuild
+++ b/dev-vcs/git/git-1.7.5_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.5_rc1.ebuild,v 1.1 2011/04/06 23:07:49 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.5_rc1.ebuild,v 1.2 2011/08/19 18:43:47 darkside Exp $
EAPI=3
@@ -497,10 +497,6 @@ showpkgdeps() {
pkg_postinst() {
use emacs && elisp-site-regen
use python && python_mod_optimize git_remote_helpers
- if use subversion && has_version dev-vcs/subversion && ! built_with_use --missing false dev-vcs/subversion perl ; then
- ewarn "You must build dev-vcs/subversion with USE=perl"
- ewarn "to get the full functionality of git-svn!"
- fi
elog "These additional scripts need some dependencies:"
echo
showpkgdeps git-quiltimport "dev-util/quilt"
diff --git a/dev-vcs/git/git-1.7.5_rc3.ebuild b/dev-vcs/git/git-1.7.5_rc3.ebuild
index 21c0b81bec01..1a493014c91c 100644
--- a/dev-vcs/git/git-1.7.5_rc3.ebuild
+++ b/dev-vcs/git/git-1.7.5_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.5_rc3.ebuild,v 1.2 2011/05/03 06:57:02 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.5_rc3.ebuild,v 1.3 2011/08/19 18:43:47 darkside Exp $
EAPI=3
@@ -495,10 +495,6 @@ showpkgdeps() {
pkg_postinst() {
use emacs && elisp-site-regen
use python && python_mod_optimize git_remote_helpers
- if use subversion && has_version dev-vcs/subversion && ! built_with_use --missing false dev-vcs/subversion perl ; then
- ewarn "You must build dev-vcs/subversion with USE=perl"
- ewarn "to get the full functionality of git-svn!"
- fi
elog "These additional scripts need some dependencies:"
echo
showpkgdeps git-quiltimport "dev-util/quilt"
diff --git a/dev-vcs/git/git-1.7.6.ebuild b/dev-vcs/git/git-1.7.6.ebuild
index 9ad3457529d7..78bdf8410e6f 100644
--- a/dev-vcs/git/git-1.7.6.ebuild
+++ b/dev-vcs/git/git-1.7.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.6.ebuild,v 1.2 2011/07/13 07:03:15 mduft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.6.ebuild,v 1.3 2011/08/19 18:43:47 darkside Exp $
EAPI=3
@@ -506,10 +506,6 @@ pkg_postinst() {
use python && python_mod_optimize git_remote_helpers
use bash-completion && \
einfo "Please read /usr/share/bash-completion/git for Git bash completion"
- if use subversion && has_version dev-vcs/subversion && ! built_with_use --missing false dev-vcs/subversion perl ; then
- ewarn "You must build dev-vcs/subversion with USE=perl"
- ewarn "to get the full functionality of git-svn!"
- fi
elog "These additional scripts need some dependencies:"
echo
showpkgdeps git-quiltimport "dev-util/quilt"
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 742fbc614915..256a6bce0a2d 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.22 2011/06/27 19:56:45 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.23 2011/08/19 18:43:47 darkside Exp $
EAPI=3
@@ -504,10 +504,6 @@ pkg_postinst() {
use python && python_mod_optimize git_remote_helpers
use bash-completion && \
einfo "Please read /usr/share/bash-completion/git for Git bash completion"
- if use subversion && has_version dev-vcs/subversion && ! built_with_use --missing false dev-vcs/subversion perl ; then
- ewarn "You must build dev-vcs/subversion with USE=perl"
- ewarn "to get the full functionality of git-svn!"
- fi
elog "These additional scripts need some dependencies:"
echo
showpkgdeps git-quiltimport "dev-util/quilt"