summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild')
-rw-r--r--games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild b/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild
index 345c4aa05fbc..bc1e0894524d 100644
--- a/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild
+++ b/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild,v 1.1 2006/10/29 20:23:13 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild,v 1.2 2006/10/31 06:51:59 tupone Exp $
inherit eutils kde games
@@ -21,6 +21,13 @@ S=${WORKDIR}/${PN}-${PV%_*}
need-kde 3.5.2
+src_compile() {
+ local myconf
+ kde_src_compile myconf
+ egamesconf $myconf || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS NEWS TODO