summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/searchtool/searchtool-0.4.4.ebuild')
-rw-r--r--games-util/searchtool/searchtool-0.4.4.ebuild23
1 files changed, 10 insertions, 13 deletions
diff --git a/games-util/searchtool/searchtool-0.4.4.ebuild b/games-util/searchtool/searchtool-0.4.4.ebuild
index 557a1805c506..bad75946ec86 100644
--- a/games-util/searchtool/searchtool-0.4.4.ebuild
+++ b/games-util/searchtool/searchtool-0.4.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/searchtool/searchtool-0.4.4.ebuild,v 1.5 2005/06/05 11:35:25 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/searchtool/searchtool-0.4.4.ebuild,v 1.6 2006/10/17 19:41:25 nyhm Exp $
-inherit games
+inherit java-ant-2 java-pkg-2 games
DESCRIPTION="server browser for Internet games"
HOMEPAGE="http://searchtool.sourceforge.net/"
@@ -13,23 +13,20 @@ SLOT="0"
KEYWORDS="ppc x86"
IUSE=""
-DEPEND="dev-java/ant"
-RDEPEND="virtual/jre"
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant"
+RDEPEND=">=virtual/jre-1.4"
-S="${WORKDIR}/${PN}"
+S=${WORKDIR}/${PN}
src_compile() {
- ant || die "ant failed"
- sed \
- -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
- -e "s:GENTOO_P:${P}:" \
- ${FILESDIR}/searchtool > searchtool
+ eant || die
}
src_install() {
- dogamesbin searchtool || die "dogamesbin failed"
+ games_make_wrapper ${PN} "java -jar ${P}.jar" "${GAMES_DATADIR}/${PN}"
insinto "${GAMES_DATADIR}/${PN}"
- doins ${P}.jar
+ doins ${P}.jar || die "doins failed"
dodoc README
prepgamesdirs
}