summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/libgnomeprint')
-rw-r--r--gnome-base/libgnomeprint/ChangeLog7
-rw-r--r--gnome-base/libgnomeprint/files/digest-libgnomeprint-2.1.11
-rw-r--r--gnome-base/libgnomeprint/libgnomeprint-2.1.1.ebuild62
3 files changed, 69 insertions, 1 deletions
diff --git a/gnome-base/libgnomeprint/ChangeLog b/gnome-base/libgnomeprint/ChangeLog
index 52ad4e6ffbf2..39a50843471d 100644
--- a/gnome-base/libgnomeprint/ChangeLog
+++ b/gnome-base/libgnomeprint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/libgnomeprint
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/ChangeLog,v 1.8 2002/11/12 00:34:44 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/ChangeLog,v 1.9 2002/11/13 00:25:15 foser Exp $
+
+*libgnomeprint-2.1.1 (12 Nov 2002)
+
+ 12 Nov 2002; foser <foser@gentoo.org> libgnomeprint-2.1.1.ebuild :
+ GNOME 2.1.2 release
*libgnomeprint-1.116.1 (24 Oct 2002)
diff --git a/gnome-base/libgnomeprint/files/digest-libgnomeprint-2.1.1 b/gnome-base/libgnomeprint/files/digest-libgnomeprint-2.1.1
new file mode 100644
index 000000000000..2628d7045883
--- /dev/null
+++ b/gnome-base/libgnomeprint/files/digest-libgnomeprint-2.1.1
@@ -0,0 +1 @@
+MD5 ced8d54c1cc3841185c0d4ba492d75d5 libgnomeprint-2.1.1.tar.bz2 543146
diff --git a/gnome-base/libgnomeprint/libgnomeprint-2.1.1.ebuild b/gnome-base/libgnomeprint/libgnomeprint-2.1.1.ebuild
new file mode 100644
index 000000000000..ba4f15acd762
--- /dev/null
+++ b/gnome-base/libgnomeprint/libgnomeprint-2.1.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/libgnomeprint-2.1.1.ebuild,v 1.1 2002/11/13 00:25:15 foser Exp $
+
+inherit libtool gnome2 debug
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Printer handling for Gnome"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="2.2"
+KEYWORDS="x86 ppc sparc sparc64"
+LICENSE="GPL-2 LGPL-2.1"
+
+
+RDEPEND="=gnome-base/libbonobo-2.1*
+ >=media-libs/libart_lgpl-2.3.8
+ =x11-libs/pango-1.1*
+ >=dev-libs/libxml2-2.4.22
+ >=dev-libs/glib-2.0.0
+ >=media-libs/freetype-2.0.9"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( dev-util/gtk-doc )"
+
+src_compile() {
+ elibtoolize
+ local myconf
+ use doc && myconf="--enable-gtk-doc" || myconf="--disable-gtk-doc"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --disable-font-install \
+ --enable-platform-gnome-2 \
+ ${myconf} || die "configure failure"
+
+ emake || die "compile failure"
+}
+
+src_install() {
+ make DESTDIR=${D} \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog* INSTALL NEWS README
+}
+
+pkg_postinst() {
+ echo ">>> Updating Fonts"
+ libgnomeprint-2.0-font-install \
+ --debug \
+ --smart \
+ --static \
+ --aliases=/usr/share/gnome/libgnomeprint-2.0/fonts/adobe-urw.font \
+ --target=/usr/share/gnome/libgnomeprint-2.0/fonts/gnome-print.fontmap
+}