summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/dolphin-plugins')
-rw-r--r--kde-base/dolphin-plugins/ChangeLog8
-rw-r--r--kde-base/dolphin-plugins/dolphin-plugins-4.10.0.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-base/dolphin-plugins/ChangeLog b/kde-base/dolphin-plugins/ChangeLog
index 65a607142bcb..0caa9fb723d2 100644
--- a/kde-base/dolphin-plugins/ChangeLog
+++ b/kde-base/dolphin-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/dolphin-plugins
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/ChangeLog,v 1.79 2013/01/28 12:12:30 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/ChangeLog,v 1.80 2013/02/07 04:57:30 alexxy Exp $
+
+*dolphin-plugins-4.10.0 (06 Feb 2013)
+
+ 06 Feb 2013; Alexey Shvetsov <alexxy@gentoo.org>
+ +dolphin-plugins-4.10.0.ebuild:
+ Version bump KDE SC 4.10.0
28 Jan 2013; Agostino Sarubbo <ago@gentoo.org> -dolphin-plugins-4.9.3.ebuild,
-dolphin-plugins-4.9.4.ebuild:
diff --git a/kde-base/dolphin-plugins/dolphin-plugins-4.10.0.ebuild b/kde-base/dolphin-plugins/dolphin-plugins-4.10.0.ebuild
new file mode 100644
index 000000000000..495cd6ab4ecf
--- /dev/null
+++ b/kde-base/dolphin-plugins/dolphin-plugins-4.10.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/dolphin-plugins-4.10.0.ebuild,v 1.1 2013/02/07 04:57:30 alexxy Exp $
+
+EAPI=5
+
+KMNAME="kdesdk"
+KDE_SCM="svn"
+inherit kde4-meta
+
+DESCRIPTION="Extra Dolphin plugins"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug bazaar git mercurial subversion"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kompare)
+ bazaar? ( dev-vcs/bzr )
+ git? ( dev-vcs/git )
+ mercurial? ( dev-vcs/mercurial )
+ subversion? ( dev-vcs/subversion )
+"
+
+KMLOADLIBS="libkonq"
+
+src_install() {
+ { use bazaar || use git || use mercurial || use subversion; } && kde4-meta_src_install
+}
+
+pkg_postinst() {
+ if ! use bazaar && ! use git && ! use mercurial && ! use subversion ; then
+ einfo
+ einfo "You have disabled all plugin use flags. If you want to have vcs"
+ einfo "integration in dolphin, enable those of your needs."
+ einfo
+ fi
+}