summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/perlqt')
-rw-r--r--kde-base/perlqt/ChangeLog7
-rw-r--r--kde-base/perlqt/perlqt-4.7.3.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/kde-base/perlqt/ChangeLog b/kde-base/perlqt/ChangeLog
index 52e420a508a8..4a95edfd254f 100644
--- a/kde-base/perlqt/ChangeLog
+++ b/kde-base/perlqt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/perlqt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.9 2011/10/28 19:03:44 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.10 2011/11/02 20:48:21 alexxy Exp $
+
+*perlqt-4.7.3 (02 Nov 2011)
+
+ 02 Nov 2011; Alexey Shvetsov <alexxy@gentoo.org> +perlqt-4.7.3.ebuild:
+ Version bump KDE SC 4.7.3
28 Oct 2011; Andreas K. Huettel <dilfridge@gentoo.org> -perlqt-4.7.1.ebuild,
-perlqt-4.7.1-r1.ebuild:
diff --git a/kde-base/perlqt/perlqt-4.7.3.ebuild b/kde-base/perlqt/perlqt-4.7.3.ebuild
new file mode 100644
index 000000000000..09ba2ef34cd6
--- /dev/null
+++ b/kde-base/perlqt/perlqt-4.7.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/perlqt-4.7.3.ebuild,v 1.1 2011/11/02 20:48:21 alexxy Exp $
+
+EAPI=4
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+KDE_REQUIRED="never"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="Qt Perl bindings"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug phonon qimageblitz qscintilla qwt test webkit"
+
+RDEPEND="
+ >=dev-lang/perl-5.10.1
+ $(add_kdebase_dep smokeqt 'declarative?,multimedia?,opengl?,phonon?,qimageblitz?,qscintilla?,qthelp?,qwt?,webkit?')
+"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/List-MoreUtils )
+"
+
+# Split from kdebindings-perl in 4.7
+add_blocker kdebindings-perl
+
+PATCHES=( "${FILESDIR}/${PN}-4.7.2-vendor.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}