summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/pykde4')
-rw-r--r--kde-base/pykde4/ChangeLog7
-rw-r--r--kde-base/pykde4/pykde4-4.3.3.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/kde-base/pykde4/ChangeLog b/kde-base/pykde4/ChangeLog
index efd30c9abee4..1d8d633e695c 100644
--- a/kde-base/pykde4/ChangeLog
+++ b/kde-base/pykde4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/pykde4
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.32 2009/10/18 13:48:04 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.33 2009/11/02 22:10:29 wired Exp $
+
+*pykde4-4.3.3 (02 Nov 2009)
+
+ 02 Nov 2009; Alex Alexander <wired@gentoo.org> +pykde4-4.3.3.ebuild:
+ Version bump
18 Oct 2009; Markus Meier <maekke@gentoo.org> pykde4-4.3.1.ebuild:
x86 stable, bug #287697
diff --git a/kde-base/pykde4/pykde4-4.3.3.ebuild b/kde-base/pykde4/pykde4-4.3.3.ebuild
new file mode 100644
index 000000000000..2e33c5c99092
--- /dev/null
+++ b/kde-base/pykde4/pykde4-4.3.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/pykde4-4.3.3.ebuild,v 1.1 2009/11/02 22:10:29 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdebindings"
+KMMODULE="python/${PN}"
+OPENGL_REQUIRED="always"
+PYTHON_USE_WITH="threads"
+inherit python kde4-meta
+
+DESCRIPTION="Python bindings for KDE4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="akonadi debug examples policykit semantic-desktop"
+
+COMMON_DEPEND="
+ >=dev-python/PyQt4-4.5[dbus,sql,svg,webkit,X]
+ $(add_kdebase_dep kdelibs 'opengl,semantic-desktop?')
+ akonadi? ( $(add_kdebase_dep kdepimlibs) )
+ policykit? ( >=sys-auth/policykit-qt-0.9.2 )
+"
+DEPEND="${COMMON_DEPEND}"
+# blocker added due to compatibility issues and error during compile time
+RDEPEND="${COMMON_DEPEND}
+ !dev-python/pykde
+"
+
+pkg_setup() {
+ python_pkg_setup
+ kde4-meta_pkg_setup
+}
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ if ! use examples; then
+ sed -e '/^ADD_SUBDIRECTORY(examples)/s/^/# DISABLED /' -i python/${PN}/CMakeLists.txt \
+ || die "Failed to disable examples"
+ fi
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ -DWITH_QScintilla=OFF
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_with policykit PolkitQt)
+ "
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ python_version
+ rm -f \
+ "${D}/usr/$(get_libdir)/python${PYVER}"/site-packages/PyKDE4/*.py[co] \
+ "${D}${PREFIX}"/share/apps/"${PN}"/*.py[co]
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ python_mod_optimize ${ROOT}"usr/$(get_libdir)/python${PYVER}"/site-packages/PyKDE4
+
+ if use examples; then
+ echo
+ elog "PyKDE4 examples have been installed to"
+ elog "${PREFIX}/share/apps/${PN}/examples"
+ echo
+ fi
+}
+
+pkg_postrm() {
+ kde4-meta_pkg_postrm
+
+ python_mod_cleanup ${ROOT}"usr/$(get_libdir)/python${PYVER}"/site-packages/PyKDE4
+}