summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/eog/eog-2.14.1.ebuild')
-rw-r--r--media-gfx/eog/eog-2.14.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/media-gfx/eog/eog-2.14.1.ebuild b/media-gfx/eog/eog-2.14.1.ebuild
new file mode 100644
index 000000000000..9ce3fd0ca2b5
--- /dev/null
+++ b/media-gfx/eog/eog-2.14.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-2.14.1.ebuild,v 1.1 2006/05/01 20:29:34 dang Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Eye Of Gnome, an image viewer"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="jpeg lcms"
+
+RDEPEND=">=gnome-base/gnome-vfs-2.5.91
+ >=gnome-base/libgnomeui-2.5.92
+ >=gnome-base/libglade-2.3.6
+ >=x11-libs/gtk+-2.7.1
+ >=gnome-base/libgnomecanvas-2.5.92
+ >=gnome-base/gconf-2.5.90
+ >=media-libs/libart_lgpl-2.3.16
+ >=gnome-base/libgnomeprintui-2.2
+ >=gnome-base/libgnomeprint-2.2
+ >=gnome-base/gnome-desktop-2.10
+ dev-libs/popt
+ jpeg? (
+ >=media-libs/libexif-0.6.12
+ media-libs/jpeg )
+ lcms? ( media-libs/lcms )"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/intltool-0.28
+ >=dev-util/pkgconfig-0.17"
+
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README THANKS TODO"
+
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_with jpeg libjpeg) \
+ $(use_with jpeg libexif) \
+ $(use_with lcms cms)"
+}
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ # Fix pkg-config detection if --without-libexif is passed.
+ epatch ${FILESDIR}/${PN}-2.11.90-pkgconfig_macro.patch
+
+ autoconf || die "autoconf failed"
+
+ gnome2_omf_fix
+}