summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libtheora/files')
-rw-r--r--media-libs/libtheora/files/libtheora-1.0_beta3-tests.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-libs/libtheora/files/libtheora-1.0_beta3-tests.patch b/media-libs/libtheora/files/libtheora-1.0_beta3-tests.patch
new file mode 100644
index 000000000000..2dcef60d61d1
--- /dev/null
+++ b/media-libs/libtheora/files/libtheora-1.0_beta3-tests.patch
@@ -0,0 +1,29 @@
+https://trac.xiph.org/ticket/1423
+
+Index: libtheora-1.0beta3/tests/Makefile.am
+===================================================================
+--- libtheora-1.0beta3.orig/tests/Makefile.am
++++ libtheora-1.0beta3/tests/Makefile.am
+@@ -13,12 +13,19 @@ test: check
+
+ TESTS_ENVIRONMENT = $(VALGRIND_ENVIRONMENT)
+
+-TESTS = noop noop_theoraenc noop_theora \
+- comment comment_theoradec comment_theora \
++TESTS_DEC = noop_theora \
++ comment comment_theoradec comment_theora
++
++TESTS_ENC = noop noop_theoraenc \
+ granulepos granulepos_theoraenc granulepos_theora
+
+-noinst_PROGRAMS = $(TESTS)
++if THEORA_DISABLE_ENCODE
++TESTS = $(TESTS_DEC)
++else
++TESTS = $(TESTS_DEC) $(TESTS_ENC)
++endif
+
++check_PROGRAMS = $(TESTS)
+ # dummy call tests for the current api
+ noop_SOURCES = noop.c
+ noop_LDADD = $(THEORAENC_LIBS)