summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nagios/nagios-3.0.2.ebuild')
-rw-r--r--net-analyzer/nagios/nagios-3.0.2.ebuild29
1 files changed, 28 insertions, 1 deletions
diff --git a/net-analyzer/nagios/nagios-3.0.2.ebuild b/net-analyzer/nagios/nagios-3.0.2.ebuild
index f797ec2f3710..8bb730186953 100644
--- a/net-analyzer/nagios/nagios-3.0.2.ebuild
+++ b/net-analyzer/nagios/nagios-3.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/nagios-3.0.2.ebuild,v 1.2 2008/05/29 13:02:52 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/nagios-3.0.2.ebuild,v 1.3 2008/06/08 16:31:25 dertobi123 Exp $
DESCRIPTION="The Nagios metapackage - merge this to pull install all of the
nagios packages"
@@ -15,6 +15,33 @@ RDEPEND="~net-analyzer/nagios-core-${PV}
>=net-analyzer/nagios-plugins-1.4.12-r100
>=net-analyzer/nagios-imagepack-1.0-r100"
+pkg_setup() {
+ # Avoid upgrading from Nagios <3 as the directory structure has changed
+ if [[ -f /var/lib/init.d/started/nagios ]] ; then
+ if has_version '<net-analyzer/nagios-3.0' ; then
+ if [[ "${FORCE_UPGRADE}" ]] ; then
+ echo
+ ewarn "you are upgrading from an incompatible version and have"
+ ewarn "FORCE_UPGRADE set, will build this package while Nagios is running."
+ echo
+ else
+ echo
+ eerror "You are upgrading from an incompatible version."
+ eerror "Please be advised that installation paths have changed to a more FHS"
+ eerror "compliant structure and you won't be able to easily upgrade to"
+ eerror "Nagios 3 therefore. You will have to change your configuration"
+ eerror "to reflect this change, for example Nagios plugins are now installed"
+ eerror "into /usr/$(get_libdir)/nagios/plugins/ instead of /usr/nagios/libexec."
+ echo
+ eerror "If you want to upgrade now, emerge nagios with:"
+ eerror " FORCE_UPGRADE=1 emerge nagios"
+ die "Upgrading from an incompatible version!"
+ echo
+ fi
+ fi
+ fi
+}
+
pkg_postrm() {
elog "Note: this is a META ebuild for ${P}."
elog "to remove it completely or before re-emerging"