summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nettop/nettop-0.2.3.ebuild')
-rw-r--r--net-analyzer/nettop/nettop-0.2.3.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/net-analyzer/nettop/nettop-0.2.3.ebuild b/net-analyzer/nettop/nettop-0.2.3.ebuild
index 4b0e110562c5..faa1b7ebed5c 100644
--- a/net-analyzer/nettop/nettop-0.2.3.ebuild
+++ b/net-analyzer/nettop/nettop-0.2.3.ebuild
@@ -1,30 +1,33 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nettop/nettop-0.2.3.ebuild,v 1.1 2003/09/14 17:58:16 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nettop/nettop-0.2.3.ebuild,v 1.1.1.1 2005/11/30 10:12:11 chriswhite Exp $
+
+inherit eutils
IUSE=""
-S=${WORKDIR}/${P}
DESCRIPTION="top like program for network activity"
SRC_URI="http://srparish.net/scripts/${P}.tar.gz"
HOMEPAGE="http://srparish.net/software/"
SLOT="0"
LICENSE="BSD"
-KEYWORDS="x86"
+KEYWORDS="x86 sparc ppc ~amd64"
DEPEND="sys-libs/slang
- net-libs/libpcap"
+ virtual/libpcap"
src_compile() {
+ epatch ${FILESDIR}/nettop.c.patch
+
local myconf
myconf="--prefix=/usr"
./configure ${myconf} || die
- emake
+ emake || die
}
src_install() {
- dosbin nettop
+ dosbin nettop || die
dodoc ChangeLog README THANKS
}