summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/snort/files')
-rw-r--r--net-analyzer/snort/files/2.1.1-libnet-1.0.patch57
-rw-r--r--net-analyzer/snort/files/digest-snort-2.1.11
-rw-r--r--net-analyzer/snort/files/snort-2.1.1-gcc3.patch12
-rw-r--r--net-analyzer/snort/files/snort-2.1.1-pgsql.patch17
4 files changed, 87 insertions, 0 deletions
diff --git a/net-analyzer/snort/files/2.1.1-libnet-1.0.patch b/net-analyzer/snort/files/2.1.1-libnet-1.0.patch
new file mode 100644
index 000000000000..c26fa717ba1c
--- /dev/null
+++ b/net-analyzer/snort/files/2.1.1-libnet-1.0.patch
@@ -0,0 +1,57 @@
+--- configure.orig 2003-08-19 01:19:05.948824752 -0400
++++ configure 2003-08-19 01:19:06.212784624 -0400
+@@ -6376 +6376 @@
+- CPPFLAGS="${CPPFLAGS} -DENABLE_RESPONSE `libnet-config --defines --cflags`" LDFLAGS="${LDFLAGS} `libnet-config --libs`"
++ CPPFLAGS="${CPPFLAGS} -DENABLE_RESPONSE `libnet-1.0-config --defines --cflags`" LDFLAGS="${LDFLAGS} `libnet-1.0-config --libs`"
+@@ -6382 +6382 @@
+- if test `libnet-config --cflags | wc -c` = "1"; then
++ if test `libnet-1.0-config --cflags | wc -c` = "1"; then
+@@ -6387,3 +6387,3 @@
+- if test `libnet-config --libs | wc -c` = "1"; then
+- { echo "$as_me:$LINENO: WARNING: libnet-config --libs is broken on your system. If you" >&5
+-echo "$as_me: WARNING: libnet-config --libs is broken on your system. If you" >&2;}
++ if test `libnet-1.0-config --libs | wc -c` = "1"; then
++ { echo "$as_me:$LINENO: WARNING: libnet-1.0-config --libs is broken on your system. If you" >&5
++echo "$as_me: WARNING: libnet-1.0-config --libs is broken on your system. If you" >&2;}
+@@ -6395 +6395 @@
+- LIBS="${LIBS} -lnet"
++ LIBS="${LIBS} -lnet-1.0"
+@@ -6400 +6400 @@
+-for ac_header in libnet.h
++for ac_header in libnet-1.0.h
+@@ -6533 +6533 @@
+- libnet_dir=`libnet-config --cflags | cut -dI -f2`
++ libnet_dir=`libnet-1.0-config --cflags | cut -dI -f2`
+@@ -6538 +6538 @@
+- if test -r $i/libnet.h; then
++ if test -r $i/libnet-1.0.h; then
+@@ -6544 +6544 @@
+- if eval "grep LIBNET_VERSION $LIBNET_INC_DIR/libnet.h | grep -v 1.0.2a >/dev/null"; then
++ if eval "grep LIBNET_VERSION $LIBNET_INC_DIR/libnet-1.0.h | grep -v 1.0.2a >/dev/null"; then
+@@ -6555 +6555 @@
+- echo " ERROR: unable to find" "libnet 1.0.2a (libnet.h)"
++ echo " ERROR: unable to find" "libnet 1.0.2a (libnet-1.0.h)"
+@@ -6574 +6574 @@
+- echo " ERROR: unable to find" "libnet 1.0.2a (libnet.h)"
++ echo " ERROR: unable to find" "libnet 1.0.2a (libnet-1.0.h)"
+@@ -6587,2 +6587,2 @@
+-echo "$as_me:$LINENO: checking for libnet_build_ip in -lnet" >&5
+-echo $ECHO_N "checking for libnet_build_ip in -lnet... $ECHO_C" >&6
++echo "$as_me:$LINENO: checking for libnet_build_ip in -lnet-1.0" >&5
++echo $ECHO_N "checking for libnet_build_ip in -lnet-1.0... $ECHO_C" >&6
+@@ -6593 +6593 @@
+-LIBS="-lnet $LIBS"
++LIBS="-lnet-1.0 $LIBS"
+@@ -6647 +6647 @@
+- LIBS="-lnet $LIBS"
++ LIBS="-lnet-1.0 $LIBS"
+--- src/detection-plugins/sp_react.c.orig 2003-08-19 01:19:06.106800736 -0400
++++ src/detection-plugins/sp_react.c 2003-08-19 01:19:06.220783408 -0400
+@@ -56 +56 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+--- src/detection-plugins/sp_respond.c.orig 2003-08-19 01:19:06.111799976 -0400
++++ src/detection-plugins/sp_respond.c 2003-08-19 01:19:06.225782648 -0400
+@@ -33 +33 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
diff --git a/net-analyzer/snort/files/digest-snort-2.1.1 b/net-analyzer/snort/files/digest-snort-2.1.1
new file mode 100644
index 000000000000..a0eae381c199
--- /dev/null
+++ b/net-analyzer/snort/files/digest-snort-2.1.1
@@ -0,0 +1 @@
+MD5 f53ce230616c1f6aafedf546a7cc0f0f snort-2.1.1.tar.gz 2309735
diff --git a/net-analyzer/snort/files/snort-2.1.1-gcc3.patch b/net-analyzer/snort/files/snort-2.1.1-gcc3.patch
new file mode 100644
index 000000000000..972aee39c74a
--- /dev/null
+++ b/net-analyzer/snort/files/snort-2.1.1-gcc3.patch
@@ -0,0 +1,12 @@
+diff -ur snort-2.0.2/src/util.h snort-2.0.2-gentoo/src/util.h
+--- snort-2.0.2/src/util.h 2003-03-27 09:59:30.000000000 +1200
++++ snort-2.0.2-gentoo/src/util.h 2003-10-10 02:11:41.000000000 +1300
+@@ -39,6 +39,8 @@
+ #include "strlcpyu.h"
+ #endif
+
++#include <sys/types.h>
++
+ extern u_long netmasks[33];
+
+ /* Self preservation memory control struct */
diff --git a/net-analyzer/snort/files/snort-2.1.1-pgsql.patch b/net-analyzer/snort/files/snort-2.1.1-pgsql.patch
new file mode 100644
index 000000000000..46d62711ea12
--- /dev/null
+++ b/net-analyzer/snort/files/snort-2.1.1-pgsql.patch
@@ -0,0 +1,17 @@
+Index: configure.in
+===================================================================
+RCS file: /cvsroot/snort/snort/configure.in,v
+retrieving revision 1.129
+diff -u -b -B -w -p -r1.129 configure.in
+--- configure.in 17 Dec 2003 21:25:13 -0000 1.129
++++ configure.in 8 Jan 2004 11:50:34 -0000
+@@ -511,6 +511,9 @@ if test "$with_postgresql" != "no"; then
+ elif test -r $i/include/postgresql/libpq-fe.h; then
+ POSTGRESQL_DIR=$i
+ POSTGRESQL_INC_DIR=$i/include/postgresql
++ elif test -r $i/include/postgresql/pgsql/libpq-fe.h; then
++ POSTGRESQL_DIR=$i
++ POSTGRESQL_INC_DIR=$i/include/postgresql/pgsql
+ fi
+ done
+