summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/tcpdump/tcpdump-3.8.3-r1.ebuild')
-rw-r--r--net-analyzer/tcpdump/tcpdump-3.8.3-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-analyzer/tcpdump/tcpdump-3.8.3-r1.ebuild b/net-analyzer/tcpdump/tcpdump-3.8.3-r1.ebuild
new file mode 100644
index 000000000000..3984a00a7896
--- /dev/null
+++ b/net-analyzer/tcpdump/tcpdump-3.8.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-3.8.3-r1.ebuild,v 1.1 2004/04/01 04:15:08 solar Exp $
+
+inherit flag-o-matic
+
+IUSE="ssl"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A Tool for network monitoring and data acquisition"
+SRC_URI="mirror://sourceforge/tcpdump/${P}.tar.gz
+ http://www.tcpdump.org/release/${P}.tar.gz
+ http://www.jp.tcpdump.org/release/${P}.tar.gz"
+HOMEPAGE="http://www.tcpdump.org/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~ia64 ~amd64"
+
+DEPEND=">=net-libs/libpcap-0.8.3-r1
+ ssl? ( >=dev-libs/openssl-0.9.6m )"
+
+src_compile() {
+ replace-flags -O[3-9] -O2
+
+ econf `use_with ssl crypto` `use_enable ipv6` || die
+ make CCOPT="$CFLAGS" || die
+}
+
+src_install() {
+ into /usr
+ dosbin tcpdump
+ doman tcpdump.1
+ dodoc *.awk
+ dodoc README FILES VERSION CHANGES
+}