summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/autofs')
-rw-r--r--net-fs/autofs/ChangeLog8
-rw-r--r--net-fs/autofs/autofs-5.0.3-r1.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/net-fs/autofs/ChangeLog b/net-fs/autofs/ChangeLog
index ef0337ccfe6d..c02d0c876a81 100644
--- a/net-fs/autofs/ChangeLog
+++ b/net-fs/autofs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/autofs
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.65 2008/01/31 23:19:24 stefaan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.66 2008/02/01 09:07:18 stefaan Exp $
+
+*autofs-5.0.3-r1 (01 Feb 2008)
+
+ 01 Feb 2008; Stefaan De Roeck <stefaan@gentoo.org>
+ +autofs-5.0.3-r1.ebuild:
+ Add use flag for sasl, force dependency on krb5 when using sasl (bug #208393)
*autofs-5.0.3 (31 Jan 2008)
diff --git a/net-fs/autofs/autofs-5.0.3-r1.ebuild b/net-fs/autofs/autofs-5.0.3-r1.ebuild
new file mode 100644
index 000000000000..333775746f81
--- /dev/null
+++ b/net-fs/autofs/autofs-5.0.3-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.3-r1.ebuild,v 1.1 2008/02/01 09:07:18 stefaan Exp $
+
+inherit eutils multilib autotools
+
+IUSE="ldap sasl"
+DESCRIPTION="Kernel based automounter"
+HOMEPAGE="http://www.linux-consulting.com/Amd_AutoFS/autofs.html"
+SRC_URI_BASE="mirror://kernel/linux/daemons/${PN}/v5"
+SRC_URI="${SRC_URI_BASE}/${P}.tar.bz2
+ ${SRC_URI_BASE}/${P}-ldap-page-control-configure-fix.patch
+ ${SRC_URI_BASE}/${P}-xfn-not-supported.patch
+ ${SRC_URI_BASE}/${P}-basedn-with-spaces-fix-3.patch
+ ${SRC_URI_BASE}/${P}-nfs4-tcp-only.patch
+ ${SRC_URI_BASE}/${P}-correct-ldap-lib.patch"
+DEPEND="virtual/libc
+ ldap? ( >=net-nds/openldap-2.0 )
+ sasl? ( virtual/krb5 )"
+ # currently, sasl code assumes the presence of kerberosV
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ PATCH_LIST="${P}-ldap-page-control-configure-fix.patch ${P}-xfn-not-supported.patch ${P}-basedn-with-spaces-fix-3.patch ${P}-nfs4-tcp-only.patch ${P}-correct-ldap-lib.patch"
+ for i in ${PATCH_LIST}; do
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${DISTDIR}/${i}
+ done
+
+ cd "${S}"
+ eautoconf || die "Autoconf failed"
+}
+
+src_compile() {
+ econf \
+ $(use_with ldap openldap) \
+ $(use_with sasl) \
+ --enable-ignore-busy \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ newinitd "${FILESDIR}"/autofs.rc14 autofs
+}
+
+pkg_postinst() {
+ elog "Note: If you plan on using autofs for automounting"
+ elog "remote NFS mounts without having the NFS daemon running"
+ elog "please add portmap to your default run-level."
+}