summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/netatalk/ChangeLog10
-rw-r--r--net-fs/netatalk/files/netatalk-3.0-gentoo.patch144
-rw-r--r--net-fs/netatalk/files/netatalk.init13
-rw-r--r--net-fs/netatalk/metadata.xml36
-rw-r--r--net-fs/netatalk/netatalk-2.0.5-r1.ebuild94
-rw-r--r--net-fs/netatalk/netatalk-2.2.1-r3.ebuild31
-rw-r--r--net-fs/netatalk/netatalk-2.2.2.ebuild153
-rw-r--r--net-fs/netatalk/netatalk-2.2.3.ebuild31
-rw-r--r--net-fs/netatalk/netatalk-3.0.ebuild138
9 files changed, 354 insertions, 296 deletions
diff --git a/net-fs/netatalk/ChangeLog b/net-fs/netatalk/ChangeLog
index 662ccba24e07..b956da63b18c 100644
--- a/net-fs/netatalk/ChangeLog
+++ b/net-fs/netatalk/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-fs/netatalk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/ChangeLog,v 1.86 2012/07/29 16:13:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/ChangeLog,v 1.87 2012/09/10 14:28:03 jlec Exp $
+
+*netatalk-3.0 (10 Sep 2012)
+
+ 10 Sep 2012; Justin Lecher <jlec@gentoo.org> -netatalk-2.0.5-r1.ebuild,
+ netatalk-2.2.1-r3.ebuild, -netatalk-2.2.2.ebuild, netatalk-2.2.3.ebuild,
+ +netatalk-3.0.ebuild, +files/netatalk-3.0-gentoo.patch, +files/netatalk.init,
+ metadata.xml:
+ Version Bump, #427732; removed old
29 Jul 2012; Raúl Porcel <armin76@gentoo.org> netatalk-2.2.1-r3.ebuild:
sh/sparc stable wrt #411291
diff --git a/net-fs/netatalk/files/netatalk-3.0-gentoo.patch b/net-fs/netatalk/files/netatalk-3.0-gentoo.patch
new file mode 100644
index 000000000000..5f85830d8081
--- /dev/null
+++ b/net-fs/netatalk/files/netatalk-3.0-gentoo.patch
@@ -0,0 +1,144 @@
+ Makefile.am | 8 +-------
+ etc/afpd/afp_avahi.c | 2 +-
+ etc/netatalk/Makefile.am | 4 +++-
+ etc/uams/Makefile.am | 20 ++++++++++----------
+ libatalk/dsi/Makefile.am | 1 +
+ libatalk/vfs/Makefile.am | 1 +
+ macros/netatalk.m4 | 16 ++++++++--------
+ 7 files changed, 25 insertions(+), 27 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 448375a..67ea35f 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,6 +1,6 @@
+ # Makefile.am for top level of netatalk package
+
+-SUBDIRS = libatalk libevent bin config etc man contrib distrib include doc macros test
++SUBDIRS = libatalk bin config etc man contrib distrib include doc macros test
+
+ EXTRA_DIST = CONTRIBUTORS COPYRIGHT COPYING NEWS VERSION
+
+@@ -11,9 +11,3 @@ if USE_BUILTIN_LIBEVENT
+ SUBDIRS += libevent
+ endif
+
+-if RUN_LDCONFIG
+-install-exec-hook:
+- @printf "Running ldconfig to ensure libraries installed in system library directories are added to the dynamic linker cache ... "
+- @-@NETA_LDCONFIG@
+- @printf "done\n"
+-endif
+diff --git a/etc/afpd/afp_avahi.c b/etc/afpd/afp_avahi.c
+index 5218d51..b68c266 100644
+--- a/etc/afpd/afp_avahi.c
++++ b/etc/afpd/afp_avahi.c
+@@ -174,8 +174,8 @@ static void register_stuff(void) {
+ return;
+
+ fail:
+- time(NULL);
+ // avahi_threaded_poll_quit(ctx->threaded_poll);
++ return;
+ }
+
+ /* Called when publishing of service data completes */
+diff --git a/etc/netatalk/Makefile.am b/etc/netatalk/Makefile.am
+index 10f90ce..e524602 100644
+--- a/etc/netatalk/Makefile.am
++++ b/etc/netatalk/Makefile.am
+@@ -20,4 +20,6 @@ netatalk_CFLAGS += \
+
+ netatalk_LDADD += \
+ $(top_builddir)/libevent/libevent.la
+-endif
+\ No newline at end of file
++else
++netatalk_LDADD += $(LIBEVENT_LIBS)
++endif
+diff --git a/etc/uams/Makefile.am b/etc/uams/Makefile.am
+index 3a02b83..70a2f76 100644
+--- a/etc/uams/Makefile.am
++++ b/etc/uams/Makefile.am
+@@ -95,16 +95,16 @@ uams_dhx_pam_la_CFLAGS = @SSL_CFLAGS@ @PAM_CFLAGS@
+ uams_dhx2_pam_la_CFLAGS = @LIBGCRYPT_CFLAGS@ @PAM_CFLAGS@
+ uams_gss_la_CFLAGS = @GSSAPI_CFLAGS@
+
+-uams_guest_la_LDFLAGS = -module -avoid-version
+-uams_randnum_la_LDFLAGS = -module -avoid-version @SSL_LIBS@
+-uams_passwd_la_LDFLAGS = -module -avoid-version @CRYPT_LIBS@
+-uams_pam_la_LDFLAGS = -module -avoid-version @PAM_LIBS@
+-uams_pgp_la_LDFLAGS = -module -avoid-version @SSL_LIBS@
+-uams_dhx_passwd_la_LDFLAGS = -module -avoid-version @CRYPT_LIBS@ @SSL_LIBS@
+-uams_dhx_pam_la_LDFLAGS = -module -avoid-version @CRYPT_LIBS@ @SSL_LIBS@ @PAM_LIBS@
+-uams_dhx2_passwd_la_LDFLAGS = -module -avoid-version @CRYPT_LIBS@ @LIBGCRYPT_LIBS@
+-uams_dhx2_pam_la_LDFLAGS = -module -avoid-version @LIBGCRYPT_LIBS@ @PAM_LIBS@
+-uams_gss_la_LDFLAGS = -module -avoid-version @GSSAPI_LIBS@
++uams_guest_la_LDFLAGS = -shared -module -avoid-version
++uams_randnum_la_LDFLAGS = -shared -module -avoid-version @SSL_LIBS@
++uams_passwd_la_LDFLAGS = -shared -module -avoid-version @CRYPT_LIBS@
++uams_pam_la_LDFLAGS = -shared -module -avoid-version @PAM_LIBS@
++uams_pgp_la_LDFLAGS = -shared -module -avoid-version @SSL_LIBS@
++uams_dhx_passwd_la_LDFLAGS = -shared -module -avoid-version @CRYPT_LIBS@ @SSL_LIBS@
++uams_dhx_pam_la_LDFLAGS = -shared -module -avoid-version @CRYPT_LIBS@ @SSL_LIBS@ @PAM_LIBS@
++uams_dhx2_passwd_la_LDFLAGS = -shared -module -avoid-version @CRYPT_LIBS@ @LIBGCRYPT_LIBS@
++uams_dhx2_pam_la_LDFLAGS = -shared -module -avoid-version @LIBGCRYPT_LIBS@ @PAM_LIBS@
++uams_gss_la_LDFLAGS = -shared -module -avoid-version @GSSAPI_LIBS@
+
+ #
+ # module compilation
+diff --git a/libatalk/dsi/Makefile.am b/libatalk/dsi/Makefile.am
+index 34fa76e..757c458 100644
+--- a/libatalk/dsi/Makefile.am
++++ b/libatalk/dsi/Makefile.am
+@@ -7,3 +7,4 @@ LIBS = @LIBS@
+ noinst_LTLIBRARIES = libdsi.la
+
+ libdsi_la_SOURCES = dsi_attn.c dsi_close.c dsi_cmdreply.c dsi_getsess.c dsi_getstat.c dsi_init.c dsi_opensess.c dsi_read.c dsi_tcp.c dsi_tickle.c dsi_write.c dsi_stream.c
++libdsi_la_LIBADD = $(WRAP_LIBS)
+diff --git a/libatalk/vfs/Makefile.am b/libatalk/vfs/Makefile.am
+index aa62aeb..8ac2045 100644
+--- a/libatalk/vfs/Makefile.am
++++ b/libatalk/vfs/Makefile.am
+@@ -6,4 +6,5 @@ libvfs_la_SOURCES = vfs.c unix.c ea_ad.c ea_sys.c extattr.c
+
+ if HAVE_ACLS
+ libvfs_la_SOURCES += acl.c
++libvfs_la_LIBADD = $(ACL_LIBS)
+ endif
+diff --git a/macros/netatalk.m4 b/macros/netatalk.m4
+index 3e57077..c02d750 100644
+--- a/macros/netatalk.m4
++++ b/macros/netatalk.m4
+@@ -19,15 +19,16 @@ AC_DEFUN([AC_NETATALK_LIBEVENT], [
+ AC_ARG_ENABLE(
+ bundled-libevent,
+ [AS_HELP_STRING([--disable-bundled-libevent],[whether the bundled version of libevent shall not be used (define CPPFLAGS and LDFLAGS otherwise appropiately to pick up installed version)
+- ])],
+- use_bundled_libevent=$enableval,
+- use_bundled_libevent=yes
++ ])]
+ )
+
+- if test x"$use_bundled_libevent" = x"yes" ; then
+- AC_CONFIG_SUBDIRS([libevent])
+- fi
+- AM_CONDITIONAL(USE_BUILTIN_LIBEVENT, test x"$use_bundled_libevent" = x"yes")
++ AS_IF([test x"$enable_bundled_libevent" != x"no"],
++ [AC_CONFIG_SUBDIRS([libevent])
++ AC_MSG_RESULT([no])],
++ [AC_MSG_RESULT([yes])
++ PKG_CHECK_MODULES([LIBEVENT], [libevent])])
++
++ AM_CONDITIONAL(USE_BUILTIN_LIBEVENT, test x"$enable_bundled_libevent" != x"no")
+ ])
+
+ dnl Filesystem Hierarchy Standard (FHS) compatibility
+@@ -605,7 +606,6 @@ save_CFLAGS="$CFLAGS"
+ save_LDFLAGS="$LDFLAGS"
+ save_LIBS="$LIBS"
+ CFLAGS=""
+-LDFLAGS=""
+ LIBS=""
+ LDAP_CFLAGS=""
+ LDAP_LDFLAGS=""
diff --git a/net-fs/netatalk/files/netatalk.init b/net-fs/netatalk/files/netatalk.init
new file mode 100644
index 000000000000..4b9410abcfee
--- /dev/null
+++ b/net-fs/netatalk/files/netatalk.init
@@ -0,0 +1,13 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/files/netatalk.init,v 1.1 2012/09/10 14:28:03 jlec Exp $
+
+command="/usr/sbin/${SVCNAME}"
+
+depend() {
+ need net
+ need avahi-daemon
+ use logger dns
+ after entropy
+}
diff --git a/net-fs/netatalk/metadata.xml b/net-fs/netatalk/metadata.xml
index 7291e5f40b7d..ab4f17bdcfc1 100644
--- a/net-fs/netatalk/metadata.xml
+++ b/net-fs/netatalk/metadata.xml
@@ -7,22 +7,30 @@
</maintainer>
<use>
<flag name="appletalk">
- Build support for Apple's AppleTalk (DDP) protocol and its
- utilities (atalkd, timelord, papd).
- </flag>
+ Build support for Apple's AppleTalk (DDP) protocol and its
+ utilities (atalkd, timelord, papd).
+ </flag>
<flag name="cups">
- Add support for <pkg>net-print/cups</pkg> printers in papd. This
- flag is only considered if appletalk USE flag is enabled, and is
- otherwise ignored.
- </flag>
+ Add support for <pkg>net-print/cups</pkg> printers in papd. This
+ flag is only considered if appletalk USE flag is enabled, and is
+ otherwise ignored.
+ </flag>
+ <flag name="pgp">
+ Add support pgp authentication module
+ </flag>
+ <flag name="pgp">
+ Add support pgp authentication module
+ </flag>
<flag name="quota">
- Add support for user quota on various filesystems.
- </flag>
+ Add support for user quota on various filesystems.
+ </flag>
+ <flag name="shadow">
+ Add shadow support
+ </flag>
<flag name="ssl">
- Use <pkg>dev-libs/openssl</pkg> to provide DHX User Access
- Modules. These are not used with most recent versions of OS X
- and can be kept disabled without risks.
- </flag>
- <flag name="xfs">Enable support for XFS Quota</flag>
+ Use <pkg>dev-libs/openssl</pkg> to provide DHX User Access
+ Modules. These are not used with most recent versions of OS X
+ and can be kept disabled without risks.
+ </flag>
</use>
</pkgmetadata>
diff --git a/net-fs/netatalk/netatalk-2.0.5-r1.ebuild b/net-fs/netatalk/netatalk-2.0.5-r1.ebuild
deleted file mode 100644
index 7663ae42114f..000000000000
--- a/net-fs/netatalk/netatalk-2.0.5-r1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/netatalk-2.0.5-r1.ebuild,v 1.9 2010/10/15 02:05:39 vapier Exp $
-
-EAPI=2
-
-inherit eutils pam
-
-DESCRIPTION="Kernel level implementation of the AppleTalk Protocol Suite"
-HOMEPAGE="http://netatalk.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE="cracklib cups debug kerberos pam slp ssl tcpd xfs"
-
-RDEPEND=">=sys-libs/db-4.2.52
- cracklib? ( sys-libs/cracklib )
- pam? ( virtual/pam )
- ssl? ( dev-libs/openssl )
- tcpd? ( sys-apps/tcp-wrappers )
- slp? ( net-libs/openslp )
- cups? ( net-print/cups )
- kerberos? ( virtual/krb5 )
- >=sys-apps/coreutils-7.1
- !app-text/yudit"
-DEPEND="${RDEPEND}
- xfs? ( sys-fs/xfsprogs )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-control-pam.patch
-
- # until someone that understands their config script build
- # system gets a patch pushed upstream to make
- # --enable-srvloc passed to configure also add slpd to the
- # use line on the initscript, we'll need to do it this way
- if use slp ; then
- sed -i -e '/^[[:space:]]*use\>/s:$: slpd:' \
- distrib/initscripts/rc.atalk.gentoo.tmpl || die
- fi
-}
-
-src_configure() {
- if ! use xfs ; then
- eval $(printf '%s\n' {linux,xfs}/{dqblk_xfs,libxfs,xqm,xfs_fs}.h | \
- sed -e 's:[/.]:_:g' -e 's:^:export ac_cv_header_:' -e 's:$:=no:')
- fi
-
- # Ignore --enable-gentoo, we install the init.d by hand and we avoid having
- # to sed the Makefiles to not do rc-update.
- # --enable-shadow: let build system detect shadow.h in toolchain
- econf \
- $(use_with pam) \
- $(use_enable cups) \
- $(use_enable debug) \
- $(use_enable tcpd tcp-wrappers) \
- $(use_enable kerberos krbV-uam) \
- --disable-krb4-uam \
- $(use_enable slp srvloc) \
- $(use_with ssl ssl-dir) \
- $(use_with cracklib) \
- $(use_with slp srvloc) \
- --disable-afs \
- --enable-fhs \
- --with-bdb=/usr
-}
-
-src_compile() {
- emake || die
-
- # Create the init script manually (it's more messy to --enable-gentoo)
- emake -C distrib/initscripts rc.atalk.gentoo || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc CONTRIBUTORS NEWS README TODO VERSION
-
- newinitd distrib/initscripts/rc.atalk.gentoo atalk || die
-
- # The pamd file isn't what we need, use pamd_mimic_system
- rm -rf "${D}/etc/pam.d"
- pamd_mimic_system netatalk auth account password session
-
- # Move /usr/include/netatalk to /usr/include/netatalk2 to avoid collisions
- # with /usr/include/netatalk/at.h provided by glibc (strange, uh?)
- # Packages that wants to link to netatalk should then probably change the
- # includepath then, but right now, nothing uses netatalk.
- # On a side note, it also solves collisions with freebsd-lib and other libcs
- mv "${D}"/usr/include/netatalk{,2} || die
- sed -e 's/include <netatalk/include <netatalk2/g' \
- -i "${D}"usr/include/{netatalk2,atalk}/* || die
-}
diff --git a/net-fs/netatalk/netatalk-2.2.1-r3.ebuild b/net-fs/netatalk/netatalk-2.2.1-r3.ebuild
index 6d03f35c5d91..7667693b2943 100644
--- a/net-fs/netatalk/netatalk-2.2.1-r3.ebuild
+++ b/net-fs/netatalk/netatalk-2.2.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/netatalk-2.2.1-r3.ebuild,v 1.8 2012/07/29 16:13:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/netatalk-2.2.1-r3.ebuild,v 1.9 2012/09/10 14:28:03 jlec Exp $
EAPI="4"
@@ -16,30 +16,27 @@ SLOT="0"
KEYWORDS="amd64 arm ppc ppc64 sh sparc x86 ~x86-fbsd"
IUSE="acl appletalk avahi cracklib cups debug kerberos ldap pam quota slp ssl static-libs tcpd"
-RDEPEND=">=sys-libs/db-4.2.52
- avahi? ( net-dns/avahi[dbus] )
- cracklib? ( sys-libs/cracklib )
- pam? ( virtual/pam )
- ssl? ( dev-libs/openssl )
- tcpd? ( sys-apps/tcp-wrappers )
- slp? ( net-libs/openslp )
- kerberos? ( virtual/krb5 )
- >=sys-apps/coreutils-7.1
+RDEPEND="
!app-text/yudit
dev-libs/libgcrypt
- appletalk? (
- cups? ( net-print/cups )
- )
+ sys-apps/coreutils
+ >=sys-libs/db-4.2.52
acl? (
sys-apps/attr
sys-apps/acl
)
- ldap? (
- net-nds/openldap
- )
+ appletalk? ( cups? ( net-print/cups ) )
+ avahi? ( net-dns/avahi[dbus] )
+ cracklib? ( sys-libs/cracklib )
+ kerberos? ( virtual/krb5 )
+ ldap? ( net-nds/openldap )
+ pam? ( virtual/pam )
+ slp? ( net-libs/openslp )
+ ssl? ( dev-libs/openssl )
+ tcpd? ( sys-apps/tcp-wrappers )
"
DEPEND="${RDEPEND}"
-RDEPEND="sys-apps/openrc"
+PDEPEND="sys-apps/openrc"
REQUIRED_USE="ldap? ( acl )"
diff --git a/net-fs/netatalk/netatalk-2.2.2.ebuild b/net-fs/netatalk/netatalk-2.2.2.ebuild
deleted file mode 100644
index 808f714cc46a..000000000000
--- a/net-fs/netatalk/netatalk-2.2.2.ebuild
+++ /dev/null
@@ -1,153 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/netatalk-2.2.2.ebuild,v 1.2 2012/06/26 04:40:58 zmedico Exp $
-
-EAPI="4"
-
-inherit pam eutils flag-o-matic multilib autotools
-
-RESTRICT="test"
-DESCRIPTION="Open Source AFP server and other AppleTalk-related utilities"
-HOMEPAGE="http://netatalk.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="acl appletalk avahi cracklib cups debug kerberos ldap pam quota slp ssl static-libs tcpd"
-
-RDEPEND=">=sys-libs/db-4.2.52
- avahi? ( net-dns/avahi[dbus] )
- cracklib? ( sys-libs/cracklib )
- pam? ( virtual/pam )
- ssl? ( dev-libs/openssl )
- tcpd? ( sys-apps/tcp-wrappers )
- slp? ( net-libs/openslp )
- kerberos? ( virtual/krb5 )
- >=sys-apps/coreutils-7.1
- !app-text/yudit
- dev-libs/libgcrypt
- appletalk? (
- cups? ( net-print/cups )
- )
- acl? (
- sys-apps/attr
- sys-apps/acl
- )
- ldap? (
- net-nds/openldap
- )
- "
-DEPEND="${RDEPEND}"
-RDEPEND="sys-apps/openrc"
-
-REQUIRED_USE="ldap? ( acl )"
-
-DOCS=( CONTRIBUTORS NEWS VERSION AUTHORS doc/README.AppleTalk )
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
- eautoreconf
-}
-
-src_configure() {
- local myconf=
-
- if use appletalk; then
- myconf+=" --enable-ddp --enable-timelord $(use_enable cups)"
- else
- myconf+=" --disable-ddp --disable-timelord --disable-cups"
- fi
-
- if use acl; then
- myconf+=" --with-acls $(use_with ldap)"
- else
- myconf+=" --without-acls --without-ldap"
- fi
-
- append-flags -fno-strict-aliasing
-
- # Ignore --enable-gentoo, we install the init.d by hand and we avoid having
- # to sed the Makefiles to not do rc-update.
- econf \
- $(use_enable avahi zeroconf) \
- $(use_enable debug) \
- $(use_enable kerberos krbV-uam) \
- $(use_enable quota) \
- $(use_enable slp srvloc) \
- $(use_enable static-libs static) \
- $(use_enable tcpd tcp-wrappers) \
- $(use_with cracklib) \
- $(use_with pam) \
- $(use_with ssl ssl-dir) \
- --disable-krb4-uam \
- --disable-afs \
- --enable-fhs \
- --with-bdb=/usr \
- ${myconf}
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}"/afpd.init.3 afpd
- newinitd "${FILESDIR}"/cnid_metad.init.2 cnid_metad
-
- if use appletalk; then
- newinitd "${FILESDIR}"/atalkd.init atalkd
- newinitd "${FILESDIR}"/atalk_service.init.2 timelord
- newinitd "${FILESDIR}"/atalk_service.init.2 papd
- fi
-
- use avahi || sed -i -e '/need avahi-daemon/d' "${D}"/etc/init.d/afpd
- use slp || sed -i -e '/need slpd/d' "${D}"/etc/init.d/afpd
-
- use ldap || rm "${D}"/etc/netatalk/afp_ldap.conf
-
- rm "${D}"/etc/netatalk/netatalk.conf
-
- # The pamd file isn't what we need, use pamd_mimic_system
- rm -rf "${D}/etc/pam.d"
- pamd_mimic_system netatalk auth account password session
-
- # Move /usr/include/netatalk to /usr/include/netatalk2 to avoid collisions
- # with /usr/include/netatalk/at.h provided by glibc (strange, uh?)
- # Packages that wants to link to netatalk should then probably change the
- # includepath then, but right now, nothing uses netatalk.
- # On a side note, it also solves collisions with freebsd-lib and other libcs
- mv "${D}"/usr/include/netatalk{,2} || die
- sed -i \
- -e 's/include <netatalk/include <netatalk2/g' \
- "${D}"usr/include/{netatalk2,atalk}/* || die
-
- # These are not used at all, as the uams are loaded with their .so
- # extension.
- rm "${D}"/usr/$(get_libdir)/netatalk/*.la
-
- use static-libs || rm "${D}"/usr/$(get_libdir)/*.la
-}
-
-pkg_postinst() {
- elog "Starting from version 2.2.1-r1 the netatalk init script has been split"
- elog "into different services depending on what you need to start."
- elog "This was done to make sure that all services are started and reported"
- elog "properly."
- elog ""
- elog "The new services are:"
- elog " cnid_metad"
- elog " afpd"
- if use appletalk; then
- elog " atalkd"
- elog " timelord"
- elog " papd"
- fi
- elog ""
- elog "Dependencies should be resolved automatically depending on settings"
- elog "but please report issues with this on https://bugs.gentoo.org/ if"
- elog "you find any."
- elog ""
- elog "The old configuration file /etc/netatalk/netatalk.conf is no longer"
- elog "installed, and will be ignored. The new configuration is supposed"
- elog "to be done through individual /etc/conf.d files, for everything that"
- elog "cannot be set already through their respective configuration files."
-}
diff --git a/net-fs/netatalk/netatalk-2.2.3.ebuild b/net-fs/netatalk/netatalk-2.2.3.ebuild
index 59ee5c7aa872..a2ba387ebb58 100644
--- a/net-fs/netatalk/netatalk-2.2.3.ebuild
+++ b/net-fs/netatalk/netatalk-2.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/netatalk-2.2.3.ebuild,v 1.2 2012/06/26 04:40:58 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/netatalk-2.2.3.ebuild,v 1.3 2012/09/10 14:28:03 jlec Exp $
EAPI="4"
@@ -15,30 +15,27 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="acl appletalk avahi cracklib cups debug kerberos ldap pam quota slp ssl static-libs tcpd"
-RDEPEND=">=sys-libs/db-4.2.52
- avahi? ( net-dns/avahi[dbus] )
- cracklib? ( sys-libs/cracklib )
- pam? ( virtual/pam )
- ssl? ( dev-libs/openssl )
- tcpd? ( sys-apps/tcp-wrappers )
- slp? ( net-libs/openslp )
- kerberos? ( virtual/krb5 )
- >=sys-apps/coreutils-7.1
+RDEPEND="
!app-text/yudit
dev-libs/libgcrypt
- appletalk? (
- cups? ( net-print/cups )
- )
+ sys-apps/coreutils
+ >=sys-libs/db-4.2.52
acl? (
sys-apps/attr
sys-apps/acl
)
- ldap? (
- net-nds/openldap
- )
+ appletalk? ( cups? ( net-print/cups ) )
+ avahi? ( net-dns/avahi[dbus] )
+ cracklib? ( sys-libs/cracklib )
+ kerberos? ( virtual/krb5 )
+ ldap? ( net-nds/openldap )
+ pam? ( virtual/pam )
+ slp? ( net-libs/openslp )
+ ssl? ( dev-libs/openssl )
+ tcpd? ( sys-apps/tcp-wrappers )
"
DEPEND="${RDEPEND}"
-RDEPEND="sys-apps/openrc"
+PDEPEND="sys-apps/openrc"
RESTRICT="test"
diff --git a/net-fs/netatalk/netatalk-3.0.ebuild b/net-fs/netatalk/netatalk-3.0.ebuild
new file mode 100644
index 000000000000..a9abfb17f7d6
--- /dev/null
+++ b/net-fs/netatalk/netatalk-3.0.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/netatalk-3.0.ebuild,v 1.1 2012/09/10 14:28:03 jlec Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils flag-o-matic multilib pam
+
+DESCRIPTION="Open Source AFP server and other AppleTalk-related utilities"
+HOMEPAGE="http://netatalk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="acl avahi cracklib debug pgp kerberos ldap pam quota samba +shadow ssl static-libs tcpd"
+
+RDEPEND="
+ !app-text/yudit
+ dev-libs/libgcrypt
+ sys-apps/coreutils
+ >=sys-libs/db-4.2.52
+ acl? (
+ sys-apps/attr
+ sys-apps/acl
+ )
+ avahi? ( net-dns/avahi[dbus] )
+ cracklib? ( sys-libs/cracklib )
+ kerberos? ( virtual/krb5 )
+ ldap? ( net-nds/openldap )
+ pam? ( virtual/pam )
+ ssl? ( dev-libs/openssl )
+ tcpd? ( sys-apps/tcp-wrappers )
+ "
+DEPEND="${RDEPEND}"
+PDEPEND="sys-apps/openrc"
+
+RESTRICT="test"
+
+REQUIRED_USE="ldap? ( acl )"
+
+DOCS=( CONTRIBUTORS NEWS VERSION AUTHORS doc/DEVELOPER )
+
+PATCHES=( "${FILESDIR}"/${PN}-3.0-gentoo.patch )
+
+src_configure() {
+ local myeconfargs=()
+
+ append-flags -fno-strict-aliasing
+
+ if use acl; then
+ myconf+=( --with-acls $(use_with ldap) )
+ else
+ myconf+=( --without-acls --without-ldap )
+ fi
+
+ # Ignore --with-init-style=gentoo, we install the init.d by hand and we avoid having
+ # to sed the Makefiles to not do rc-update.
+ # TODO:
+ # systemd : --with-init-style=systemd
+ myeconfargs+=(
+ --disable-silent-rules
+ $(use_enable avahi zeroconf)
+ $(use_enable debug)
+ $(use_enable debug debugging)
+ $(use_enable pgp pgp-uam)
+ $(use_enable kerberos)
+ $(use_enable kerberos krbV-uam)
+ $(use_enable quota)
+ $(use_enable tcpd tcp-wrappers)
+ $(use_with cracklib)
+ $(use_with pam)
+ $(use_with samba smbsharemodes)
+ $(use_with shadow)
+ $(use_with ssl ssl-dir)
+ --enable-overwrite
+ --disable-krb4-uam
+ --disable-afs
+ --disable-bundled-libevent
+ --with-bdb=/usr
+ --with-uams-path=/usr/$(get_libdir)/${PN}
+ --disable-silent-rules
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+
+ use avahi || sed -i -e '/need avahi-daemon/d' "${D}"/etc/init.d/${PN}
+
+ # The pamd file isn't what we need, use pamd_mimic_system
+ rm -rf "${D}/etc/pam.d"
+ pamd_mimic_system netatalk auth account password session
+}
+
+pkg_postinst() {
+ local fle
+ if [[ ${REPLACING_VERSIONS} < 3 ]]; then
+ for fle in afp_signature.conf afp_voluuid.conf; do
+ if [[ -f "${ROOT}"etc/netatalk/${fle} ]]; then
+ if [[ ! -f "${ROOT}"var/lib/netatalk/${fle} ]]; then
+ mv \
+ "${ROOT}"etc/netatalk/${fle} \
+ "${ROOT}"var/lib/netatalk/
+ fi
+ fi
+ done
+
+ echo ""
+ elog "Starting from version 3.0 only uses a single init script again"
+ elog "Please update your runlevels accordingly"
+ echo ""
+ elog "Dependencies should be resolved automatically depending on settings"
+ elog "but please report issues with this on https://bugs.gentoo.org/ if"
+ elog "you find any."
+ echo ""
+ elog "Following config files are obsolete now:"
+ elog "afpd.conf, netatalk.conf, AppleVolumes.default and afp_ldap.conf"
+ elog "in favour of"
+ elog "/etc/afp.conf"
+ echo ""
+ elog "Please convert your existing configs before you restart your daemon"
+ echo ""
+ elog "The new AppleDouble default backend is appledouble = ea"
+ elog "Existing entries will be updated on access, but can do an offline"
+ elog "conversion with"
+ elog "dbd -ruve /path/to/Volume"
+ echo ""
+ elog "For general notes on the upgrade, please visit"
+ elog "http://netatalk.sourceforge.net/3.0/htmldocs/upgrade.html"
+ echo ""
+ fi
+}