summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/aim-transport/aim-transport-20040131-r2.ebuild')
-rw-r--r--net-im/aim-transport/aim-transport-20040131-r2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-im/aim-transport/aim-transport-20040131-r2.ebuild b/net-im/aim-transport/aim-transport-20040131-r2.ebuild
new file mode 100644
index 000000000000..0f3daf57b4c7
--- /dev/null
+++ b/net-im/aim-transport/aim-transport-20040131-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/aim-transport/aim-transport-20040131-r2.ebuild,v 1.1 2004/07/09 17:50:01 humpback Exp $
+
+inherit eutils
+
+MY_PN="${PN}-stable"
+S="${WORKDIR}/${MY_PN}-${PV}"
+DESCRIPTION="AOL Instant Messaging transport for jabberd"
+
+HOMEPAGE="http://aim-transport.jabberstudio.org/"
+
+SRC_URI="http://aim-transport.jabberstudio.org/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86 ~sparc ~ppc hppa"
+
+IUSE=""
+
+DEPEND="=net-im/jabberd-1.4*"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/aimtrans.patch
+}
+
+src_compile() {
+ einfo
+ einfo "Please ignore any errors/warnings"
+ einfo
+ automake
+ libtoolize --force
+ aclocal
+ autoconf
+ ./configure --with-jabberd=/usr/include/jabberd || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ dodir /etc/jabber /usr/lib/jabberd
+ insinto /usr/lib/jabberd
+ doins src/aimtrans.so
+ insinto /etc/jabber
+ doins ${FILESDIR}/aimtrans.xml
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/aim-transport.init-r2 aim-transport
+ insinto /etc/conf.d ; newins ${FILESDIR}/aim-transport-conf.d aim-transport
+ dodoc README ${FILESDIR}/README.Gentoo TODO aim.xml
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please read /usr/share/doc/${PN}-${PVR}/README.Gentoo.gz"
+ einfo "And please notice that now aim-transport comes with a init.d script"
+ einfo "dont forget to add it to your runlevel."
+ einfo
+}