summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/err')
-rw-r--r--net-im/err/ChangeLog6
-rw-r--r--net-im/err/err-9999.ebuild56
2 files changed, 5 insertions, 57 deletions
diff --git a/net-im/err/ChangeLog b/net-im/err/ChangeLog
index f5e7738c4306..ce23bb58016c 100644
--- a/net-im/err/ChangeLog
+++ b/net-im/err/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/err
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/err/ChangeLog,v 1.5 2012/09/16 11:05:25 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/err/ChangeLog,v 1.6 2012/09/16 11:42:42 pinkbyte Exp $
+
+ 16 Sep 2012; Sergey Popov <pinkbyte@gentoo.org> -err-9999.ebuild:
+ Drop err's live ebuild, cause it is very hard to support it in consistent and
+ up-to-date state
*err-1.5.1 (16 Sep 2012)
diff --git a/net-im/err/err-9999.ebuild b/net-im/err/err-9999.ebuild
deleted file mode 100644
index b37cc2d9ad4f..000000000000
--- a/net-im/err/err-9999.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/err/err-9999.ebuild,v 1.2 2012/06/26 16:51:34 maksbotan Exp $
-
-EAPI=4
-
-EGIT_REPO_URI="git://github.com/gbin/err.git"
-
-DISTUTILS_SRC_TEST="setup.py"
-
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_DEPEND="2:2.7"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils eutils git-2 user
-
-DESCRIPTION="err is a plugin based XMPP chatbot designed to be easily deployable, extensible and maintainable."
-HOMEPAGE="http://gbin.github.com/err/"
-
-SRC_URI=""
-KEYWORDS=""
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="+plugins"
-
-DEPEND="dev-python/setuptools"
-RDEPEND="dev-python/xmpppy
- dev-python/python-daemon
- dev-python/yapsy
- plugins? ( dev-vcs/git )"
-
-pkg_setup() {
- python_pkg_setup
- ebegin "Creating err group and user"
- enewgroup 'err'
- enewuser 'err' -1 -1 -1 'err'
- eend ${?}
-}
-
-src_install() {
- distutils_src_install
- newinitd "${FILESDIR}"/errd.initd errd
- newconfd "${FILESDIR}"/errd.confd errd
- dodir /etc/${PN}
- dodir /var/lib/${PN}
- # Create plugins directory here because of err creates it itself with 0777 rights
- dodir /var/lib/${PN}/plugins
-
- keepdir /var/log/${PN}
- keepdir /var/run/${PN}
- fowners -R err:err /var/lib/${PN}
- fowners -R err:err /var/log/${PN}
- fowners -R err:err /var/run/${PN}
- insinto /etc/${PN}
- newins errbot/config-template.py config.py
-}