summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/mcabber')
-rw-r--r--net-im/mcabber/ChangeLog7
-rw-r--r--net-im/mcabber/files/digest-mcabber-0.9.13
-rw-r--r--net-im/mcabber/mcabber-0.9.1.ebuild85
3 files changed, 94 insertions, 1 deletions
diff --git a/net-im/mcabber/ChangeLog b/net-im/mcabber/ChangeLog
index f25e75eeb7e2..ff1eb592506c 100644
--- a/net-im/mcabber/ChangeLog
+++ b/net-im/mcabber/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/mcabber
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/ChangeLog,v 1.12 2007/01/22 15:22:04 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/ChangeLog,v 1.13 2007/02/26 08:35:18 wschlich Exp $
+
+*mcabber-0.9.1 (26 Feb 2007)
+
+ 26 Feb 2007; Wolfram Schlich <wschlich@gentoo.org> +mcabber-0.9.1.ebuild:
+ version bump
22 Jan 2007; Markus Rothe <corsair@gentoo.org> mcabber-0.9.0.ebuild:
Added ~ppc64
diff --git a/net-im/mcabber/files/digest-mcabber-0.9.1 b/net-im/mcabber/files/digest-mcabber-0.9.1
new file mode 100644
index 000000000000..0e6d3939297d
--- /dev/null
+++ b/net-im/mcabber/files/digest-mcabber-0.9.1
@@ -0,0 +1,3 @@
+MD5 a0e682c57388849338a63607a1ac2302 mcabber-0.9.1.tar.bz2 420985
+RMD160 6f9251f9ece93399654665af7641f06eadfcd277 mcabber-0.9.1.tar.bz2 420985
+SHA256 2b50149b24e8fe01e3fc5bb145ed253273aac5929baf706793c2711bf6643f67 mcabber-0.9.1.tar.bz2 420985
diff --git a/net-im/mcabber/mcabber-0.9.1.ebuild b/net-im/mcabber/mcabber-0.9.1.ebuild
new file mode 100644
index 000000000000..bdf1fdc7dd0d
--- /dev/null
+++ b/net-im/mcabber/mcabber-0.9.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/mcabber-0.9.1.ebuild,v 1.1 2007/02/26 08:35:18 wschlich Exp $
+
+DESCRIPTION="A small Jabber console client with various features, like MUC, SSL, PGP"
+HOMEPAGE="http://www.lilotux.net/~mikael/mcabber/"
+SRC_URI="http://www.lilotux.net/~mikael/${PN}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="ssl crypt"
+
+LANGS="de en fr nl pl uk ru"
+# localized help versions are installed only, when LINGUAS var is set
+for i in ${LANGS}; do
+ IUSE="${IUSE} linguas_${i}"
+done;
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.7-r1 )
+ crypt? ( >=app-crypt/gpgme-1.0.0 )
+ >=dev-libs/glib-2.0.0
+ sys-libs/ncurses"
+
+src_compile() {
+ econf \
+ $(use_enable crypt gpgme) \
+ $(use_with ssl) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ # clean unneeded language documentation
+ for i in ${LANGS}; do
+ ! use linguas_${i} && rm -rf ${D}/usr/share/${PN}/help/${i}
+ done
+
+ dodoc AUTHORS ChangeLog NEWS README TODO mcabberrc.example
+ dodoc doc/README_PGP.txt
+
+ # contrib themes
+ insinto /usr/share/${PN}/themes
+ doins ${S}/contrib/themes/*
+
+ # contrib generic scripts
+ exeinto /usr/share/${PN}/scripts
+ doexe ${S}/contrib/*.{pl,py,rb}
+
+ # contrib event scripts
+ exeinto /usr/share/${PN}/scripts/events
+ doexe ${S}/contrib/events/*
+}
+
+pkg_postinst() {
+ einfo
+ einfo "MCabber requires you to create a subdirectory .mcabber in your home"
+ einfo "directory and to place a configuration file there."
+ einfo "An example mcabberrc was installed as part of the documentation."
+ einfo "To create a new mcabberrc based on the example mcabberrc, execute the"
+ einfo "following commands:"
+ einfo
+ einfo " mkdir -p ~/.mcabber"
+ einfo " bzcat ${ROOT}usr/share/doc/${PF}/mcabberrc.example.bz2 >~/.mcabber/mcabberrc"
+ einfo
+ einfo "Then edit ~/.mcabber/mcabberrc with your favorite editor."
+ einfo
+ einfo "As of MCabber version 0.8.2, there is also a wizard script"
+ einfo "with which you can create all necessary configuration options."
+ einfo "To use it, simply execute the following command:"
+ einfo
+ einfo " ${ROOT}usr/share/${PN}/scripts/mcwizz.rb"
+ einfo
+ einfo "See the CONFIGURATION FILE and FILES sections of the mcabber"
+ einfo "manual page (section 1) for more information."
+ einfo
+ einfo "From version 0.9.0 on, MCabber supports PGP encryption of messages."
+ einfo "See README_PGP.txt for details."
+ einfo
+ einfo "Check out ${ROOT}usr/share/${PN} for contributed themes and event scripts."
+ einfo
+}