summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libsoup/libsoup-2.2.99.ebuild')
-rw-r--r--net-libs/libsoup/libsoup-2.2.99.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-libs/libsoup/libsoup-2.2.99.ebuild b/net-libs/libsoup/libsoup-2.2.99.ebuild
new file mode 100644
index 000000000000..c3000557b706
--- /dev/null
+++ b/net-libs/libsoup/libsoup-2.2.99.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.2.99.ebuild,v 1.1 2007/01/14 08:01:31 leio Exp $
+
+inherit gnome2
+
+DESCRIPTION="An HTTP library implementation in C"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="2.2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc ssl"
+
+RDEPEND=">=dev-libs/glib-2.6
+ >=dev-libs/libxml2-2
+ ssl? ( >=net-libs/gnutls-1 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+
+pkg_setup() {
+ G2CONF="$(use_enable ssl)"
+}