summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gsoap/ChangeLog10
-rw-r--r--net-libs/gsoap/gsoap-2.7.13.ebuild59
-rw-r--r--net-libs/gsoap/gsoap-2.8.1.ebuild71
3 files changed, 79 insertions, 61 deletions
diff --git a/net-libs/gsoap/ChangeLog b/net-libs/gsoap/ChangeLog
index cc785d70d08d..944ef30de4f1 100644
--- a/net-libs/gsoap/ChangeLog
+++ b/net-libs/gsoap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/gsoap
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.14 2010/10/05 19:33:57 maekke Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.15 2011/01/19 16:40:49 polynomial-c Exp $
+
+*gsoap-2.8.1 (19 Jan 2011)
+
+ 19 Jan 2011; Lars Wendler <polynomial-c@gentoo.org> -gsoap-2.7.13.ebuild,
+ +gsoap-2.8.1.ebuild:
+ Version bump. Removed old.
05 Oct 2010; Markus Meier <maekke@gentoo.org> gsoap-2.7.17.ebuild:
amd64/x86 stable, bug #338796
diff --git a/net-libs/gsoap/gsoap-2.7.13.ebuild b/net-libs/gsoap/gsoap-2.7.13.ebuild
deleted file mode 100644
index 0e0eab3b17d4..000000000000
--- a/net-libs/gsoap/gsoap-2.7.13.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.7.13.ebuild,v 1.4 2010/06/03 21:25:46 polynomial-c Exp $
-
-EAPI=2
-
-inherit eutils
-
-MY_P="${PN}-2.7"
-DESCRIPTION="A cross-platform open source C and C++ SDK to ease the development of SOAP/XML Web services"
-HOMEPAGE="http://gsoap2.sourceforge.net"
-SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.tar.gz"
-
-LICENSE="GPL-2 gSOAP"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc debug examples +ssl"
-
-DEPEND="sys-devel/flex
- sys-devel/bison
- sys-libs/zlib
- ssl? ( dev-libs/openssl )"
-RDEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- # Fix Pre-ISO headers
- epatch "${FILESDIR}/${PN}-2.7-fix-pre-iso-headers.patch"
-}
-
-src_configure() {
- econf $(use_enable ssl openssl) \
- $(use_enable examples samples) \
- $(use_enable debug) \
- || die "econf failed"
-}
-
-src_compile() {
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
-
- dodir /usr/share/doc/${P}
- dodoc LICENSE.txt NOTES.txt README.txt
- dohtml changelog.html
-
- if use examples; then
- insinto /usr/share/${PN}
- rm -rf gsoap/samples/Makefile* README.txt
- doins -r gsoap/samples
- fi
-
- if use doc; then
- dohtml -r gsoap/doc/
- fi
-}
diff --git a/net-libs/gsoap/gsoap-2.8.1.ebuild b/net-libs/gsoap/gsoap-2.8.1.ebuild
new file mode 100644
index 000000000000..e21aff80c9ee
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.8.1.ebuild,v 1.1 2011/01/19 16:40:49 polynomial-c Exp $
+
+EAPI=2
+
+inherit autotools eutils
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK to ease the development of SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples +ssl"
+
+DEPEND="app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+ sys-libs/zlib
+ ssl? ( dev-libs/openssl )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Fix Pre-ISO headers
+ epatch "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ # causes compilation of app-emulation/virtualbox-ose[vboxwebsrv] to
+ # break (bug #320901):
+ #epatch "${FILESDIR}/${PN}-2.7.15-use_libtool.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable examples samples) \
+ $(use_enable debug)
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.html
+
+ rm -rf "${D}"/usr/lib*/*.la
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}