summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/fetchmail/fetchmail-6.2.5-r2.ebuild')
-rw-r--r--net-mail/fetchmail/fetchmail-6.2.5-r2.ebuild91
1 files changed, 91 insertions, 0 deletions
diff --git a/net-mail/fetchmail/fetchmail-6.2.5-r2.ebuild b/net-mail/fetchmail/fetchmail-6.2.5-r2.ebuild
new file mode 100644
index 000000000000..32534d217c22
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.2.5-r2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.2.5-r2.ebuild,v 1.1 2005/04/28 18:22:34 ticho Exp $
+
+inherit eutils gnuconfig
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://www.catb.org/~esr/fetchmail/"
+SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="ssl nls ipv6 kerberos krb4 hesiod"
+
+DEPEND="virtual/libc
+ hesiod? ( net-dns/hesiod )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ kerberos? ( virtual/krb5 )
+ krb4? ( app-crypt/kth-krb )
+ sys-devel/gettext
+ sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-6.2.0-gentoo.diff || die
+ epatch ${FILESDIR}/${P}-kerberos.patch
+ # patch fixes bug #40126 (tomk@gentoo.org 2004-08-07)
+ epatch ${FILESDIR}/${P}-fetchsizelimit.patch || die
+ # this patch fixes bug #34788 (ticho@gentoo.org 2004-09-03)
+ epatch ${FILESDIR}/${P}-broken-headers.patch || die
+
+ autoconf
+ gnuconfig_update
+}
+
+src_compile() {
+ econf --disable-dependency-tracking \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_enable ipv6 inet6) \
+ $(use_with kerberos gssapi) $(use_with kerberos kerberos5) \
+ $(use_with krb4 kerberos) \
+ $(use_with ssl) \
+ $(use_with hesiod) \
+ ${myconf} || die "Configuration failed."
+ # wont compile reliably on smp (mkennedy@gentoo.org 2003-11-12)
+ make || die "Compilation failed."
+}
+
+src_install() {
+ einstall || die
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README \
+ README.NTLM README.SSL TODO COPYING MANIFEST
+
+ doman ${D}/usr/share/man/*.1
+ rm -f ${D}/usr/share/man/*.1
+
+ newinitd ${FILESDIR}/fetchmail fetchmail
+ newconfd ${FILESDIR}/conf.d-fetchmail fetchmail
+
+ docinto contrib
+ local f
+ for f in contrib/*
+ do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ einfo
+ einfo "You will not be able to use fetchmailconf(1), because you"
+ einfo "don't seem to have Python with tkinter support."
+ einfo
+ einfo "If you want to be able to use fetchmailconf(1), do the following:"
+ einfo " 1. Include 'tcltk' in USE variable in your /etc/make.conf."
+ einfo " 2. (Re-)merge Python."
+ einfo
+ fi
+
+ einfo "Please see /etc/conf.d/fetchmail if you want to adjust"
+ einfo "the polling delay used by the fetchmail init script."
+}