summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/rpcbind/ChangeLog9
-rw-r--r--net-nds/rpcbind/files/rpcbind-0.2.0-no-nss.patch34
-rw-r--r--net-nds/rpcbind/rpcbind-0.2.0.ebuild5
3 files changed, 43 insertions, 5 deletions
diff --git a/net-nds/rpcbind/ChangeLog b/net-nds/rpcbind/ChangeLog
index 52981199c6c1..6855a86d971a 100644
--- a/net-nds/rpcbind/ChangeLog
+++ b/net-nds/rpcbind/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-nds/rpcbind
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/ChangeLog,v 1.20 2012/05/21 19:18:08 xarthisius Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/ChangeLog,v 1.21 2013/02/18 22:06:43 vapier Exp $
+
+ 18 Feb 2013; Mike Frysinger <vapier@gentoo.org>
+ +files/rpcbind-0.2.0-no-nss.patch, rpcbind-0.2.0.ebuild:
+ Fix building on non-glibc systems #458024 by Mark Reiche.
21 May 2012; Kacper Kowalik <xarthisius@gentoo.org> rpcbind-0.2.0.ebuild:
Add missing inheritance of eutils.eclass
@@ -78,4 +82,3 @@
29 Dec 2007; Mike Frysinger <vapier@gentoo.org> +files/rpcbind.confd,
+files/rpcbind.initd, +metadata.xml, +rpcbind-0.1.4.ebuild:
Initial ebuild by me.
-
diff --git a/net-nds/rpcbind/files/rpcbind-0.2.0-no-nss.patch b/net-nds/rpcbind/files/rpcbind-0.2.0-no-nss.patch
new file mode 100644
index 000000000000..4e73b88de706
--- /dev/null
+++ b/net-nds/rpcbind/files/rpcbind-0.2.0-no-nss.patch
@@ -0,0 +1,34 @@
+From 112d0028cd2f4e0a3fafc83a4b2f1cb38bdbd6d4 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 18 Feb 2013 17:00:13 -0500
+Subject: [PATCH] fix building one systems w/out nss.h
+
+The nss.h header is glibc-specific, so use the existing HAVE_NSS_H define
+to avoid including/using it when it is not available.
+
+URL: http://bugs.gentoo.org/458024
+Reported-by: Mark Reiche <porphyr@gmx.de>
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ src/rpcbind.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/rpcbind.c b/src/rpcbind.c
+index 9a0504d..83dbe93 100644
+--- a/src/rpcbind.c
++++ b/src/rpcbind.c
+@@ -67,7 +67,11 @@
+ #include <pwd.h>
+ #include <string.h>
+ #include <errno.h>
++#ifdef HAVE_NSS_H
+ #include <nss.h>
++#else
++static inline void __nss_configure_lookup(const char *db, const char *s) {}
++#endif
+ #include "config.h"
+ #include "rpcbind.h"
+
+--
+1.8.1.2
+
diff --git a/net-nds/rpcbind/rpcbind-0.2.0.ebuild b/net-nds/rpcbind/rpcbind-0.2.0.ebuild
index cc195d21b8ef..5bf18ae83a4a 100644
--- a/net-nds/rpcbind/rpcbind-0.2.0.ebuild
+++ b/net-nds/rpcbind/rpcbind-0.2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/rpcbind-0.2.0.ebuild,v 1.15 2012/05/21 19:18:08 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/rpcbind-0.2.0.ebuild,v 1.16 2013/02/18 22:06:43 vapier Exp $
EAPI="2"
@@ -34,6 +34,7 @@ src_prepare() {
eautoreconf
else
epatch "${FILESDIR}"/${P}-pkgconfig.patch
+ epatch "${FILESDIR}"/${P}-no-nss.patch
eautoreconf
fi
}