summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/giftcurs')
-rw-r--r--net-p2p/giftcurs/ChangeLog6
-rw-r--r--net-p2p/giftcurs/files/digest-giftcurs-0.5.01
-rw-r--r--net-p2p/giftcurs/giftcurs-0.5.0.ebuild31
3 files changed, 37 insertions, 1 deletions
diff --git a/net-p2p/giftcurs/ChangeLog b/net-p2p/giftcurs/ChangeLog
index c7a0d33f6f47..d1adf5d402ef 100644
--- a/net-p2p/giftcurs/ChangeLog
+++ b/net-p2p/giftcurs/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for net-p2p/giftcurs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/giftcurs/ChangeLog,v 1.5 2002/07/08 02:02:55 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/giftcurs/ChangeLog,v 1.6 2002/08/29 22:31:19 sunflare Exp $
+*giftcurs-0.5.0 (29 Aug 2002)
+ 29 Aug 2002; Phil Bordelon <sunflare@gentoo.org> giftcurs-0.5.0.ebuild: Version
+ bump.
+
*giftcurs-0.4.3 (08 Jul 2002)
08 Jul 2002; Spider <spider@gentoo.org> giftcurs-0.4.3.ebuild :
new version sneaked out, I upped the dep on gift just to force people to update that too.
diff --git a/net-p2p/giftcurs/files/digest-giftcurs-0.5.0 b/net-p2p/giftcurs/files/digest-giftcurs-0.5.0
new file mode 100644
index 000000000000..8fa674c26d21
--- /dev/null
+++ b/net-p2p/giftcurs/files/digest-giftcurs-0.5.0
@@ -0,0 +1 @@
+MD5 4fa91718ad8d3af9922d3b2f83da4fab giFTcurs-0.5.0.tar.gz 284356
diff --git a/net-p2p/giftcurs/giftcurs-0.5.0.ebuild b/net-p2p/giftcurs/giftcurs-0.5.0.ebuild
new file mode 100644
index 000000000000..ba88d6d934bc
--- /dev/null
+++ b/net-p2p/giftcurs/giftcurs-0.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/giftcurs/giftcurs-0.5.0.ebuild,v 1.1 2002/08/29 22:31:19 sunflare Exp $
+
+S="${WORKDIR}/giFTcurs-${PV}"
+DESCRIPTION="a cursed frontend to the giFT (OpenFT) daemon"
+SRC_URI="mirror://sourceforge/giftcurs/giFTcurs-${PV}.tar.gz"
+HOMEPAGE="http://giftcurs.sourceforge.net"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=net-p2p/gift-0.10.0_pre020705"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local myconf
+ cd ${S}
+ use gpm || myconf="${myconf} --disable-mouse --disable-libgpm"
+ use nls || myconf="${myconf} --disable-nls"
+ ./configure --prefix=/usr --host=${CHOST} ${myconf}
+ emake || die
+}
+
+src_install() {
+
+ einstall || die
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+}