summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/limewire/limewire-4.9.37.ebuild')
-rw-r--r--net-p2p/limewire/limewire-4.9.37.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-p2p/limewire/limewire-4.9.37.ebuild b/net-p2p/limewire/limewire-4.9.37.ebuild
new file mode 100644
index 000000000000..99f3e2aff07c
--- /dev/null
+++ b/net-p2p/limewire/limewire-4.9.37.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/limewire/limewire-4.9.37.ebuild,v 1.1 2005/10/29 15:58:13 sekretarz Exp $
+
+inherit eutils
+
+IUSE="gtk"
+DESCRIPTION="Limewire Java Gnutella client"
+HOMEPAGE="http://www.limewire.com"
+SRC_URI="http://dev.gentoo.org/~sekretarz/distfiles/LimeWireOther-${PV}.zip"
+LICENSE="GPL-2 Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~ppc amd64"
+DEPEND="app-arch/unzip
+ virtual/x11
+ gtk? ( >=x11-libs/gtk+-2.4 )"
+S=${WORKDIR}/LimeWire
+PREFIX="/opt/limewire"
+
+src_compile() {
+ ( echo \#!/bin/sh
+ echo cd ${PREFIX}
+ echo export J2SE_PREEMPTCLOSE=1
+ echo java -cp .:collections.jar:xerces.jar:jl011.jar:MessagesBundles.jar:themes.jar:logicrypto.jar:GURL.jar:LimeWire.jar com.limegroup.gnutella.gui.Main
+ ) >limewire.gentoo
+
+ echo PATH=${PREFIX} > limewire.envd
+}
+
+src_install() {
+ insinto ${PREFIX}
+ doins *.jar *.war *.properties *.ver *.sh hashes *.txt
+ exeinto /usr/bin
+ newexe limewire.gentoo limewire
+
+ newenvd limewire.envd 99limewire
+
+ insinto /usr/share/icons/hicolor/32x32/apps
+ newins ${FILESDIR}/main-icon.png limewire.png
+
+ make_desktop_entry limewire LimeWire
+}
+
+pkg_postinst() {
+ use gtk || ewarn "You will probably not be able to use the gtk frontend."
+ einfo " Finished installing LimeWire into ${PREFIX}"
+}