summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/teknap')
-rw-r--r--net-p2p/teknap/ChangeLog20
-rw-r--r--net-p2p/teknap/files/digest-teknap-1.3g1
-rw-r--r--net-p2p/teknap/teknap-1.3g.ebuild54
3 files changed, 75 insertions, 0 deletions
diff --git a/net-p2p/teknap/ChangeLog b/net-p2p/teknap/ChangeLog
new file mode 100644
index 000000000000..b0caabc0969d
--- /dev/null
+++ b/net-p2p/teknap/ChangeLog
@@ -0,0 +1,20 @@
+# ChangeLog for net-p2p/teknap
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/teknap/ChangeLog,v 1.1 2002/06/25 10:26:11 bangert Exp $
+
+*teknap-1.3g (27 Apr 2002)
+
+ 27 Apr 2002; Seemant Kulleen <seemant@gentoo.org> teknap-1.3g.ebuild
+ files/digest-teknap-1.3g
+
+ Version bump. Also cleaned up the ebuild for 1.3f
+
+*teknap-1.3f-r1 (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/net-p2p/teknap/files/digest-teknap-1.3g b/net-p2p/teknap/files/digest-teknap-1.3g
new file mode 100644
index 000000000000..db7c348b2db7
--- /dev/null
+++ b/net-p2p/teknap/files/digest-teknap-1.3g
@@ -0,0 +1 @@
+MD5 8c1bf4027d9af4767a7a060532831cc9 TekNap-1.3g.tar.gz 755718
diff --git a/net-p2p/teknap/teknap-1.3g.ebuild b/net-p2p/teknap/teknap-1.3g.ebuild
new file mode 100644
index 000000000000..d05713ebd621
--- /dev/null
+++ b/net-p2p/teknap/teknap-1.3g.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/teknap/teknap-1.3g.ebuild,v 1.1 2002/06/25 10:26:11 bangert Exp $
+
+MY_P=TekNap-${PV}
+S=${WORKDIR}/TekNap
+DESCRIPTION="TekNap is a console Napster/OpenNap client"
+SRC_URI="ftp://ftp.teknap.com/pub/TekNap/${MY_P}.tar.gz"
+HOMEPAGE="http://www.TekNap.com/"
+
+DEPEND="virtual/glibc >=sys-libs/ncurses-5.2
+ gtk? ( =x11-libs/gtk+-1.2* )
+ tcpd? ( sys-apps/tcp-wrappers )
+ xmms? ( media-sound/xmms )"
+
+src_compile() {
+ local myconf
+ if [ "`use gtk`" ] ; then
+ myconf="--with-gtk"
+ fi
+ if [ "`use tcpd`" ] ; then
+ myconf="${myconf} --enable-wrap"
+ fi
+ if [ "`use xmms`" ] ; then
+ myconf="${myconf} --enable-xmms"
+ fi
+ if [ "`use ipv6`" ] ; then
+ myconf="${myconf} --enable-ipv6"
+ fi
+
+ myconf="${myconf} --enable-cdrom"
+
+ econf ${myconf} || die
+ make || die
+
+}
+
+src_install () {
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ datadir=${D}/usr/share/TekNap \
+ install || die
+ rm ${D}/usr/bin/TekNap
+ dosym TekNap-1.3f /usr/bin/TekNap
+ dodoc COPYRIGHT README TODO Changelog
+ docinto txt
+ cd doc
+ dodoc *.txt TekNap.faq bugs link-guidelines macosx.notes
+ doman TekNap.1
+}
+