summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/pymol/pymol-0.98.ebuild')
-rw-r--r--sci-chemistry/pymol/pymol-0.98.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-chemistry/pymol/pymol-0.98.ebuild b/sci-chemistry/pymol/pymol-0.98.ebuild
new file mode 100644
index 000000000000..c15576342584
--- /dev/null
+++ b/sci-chemistry/pymol/pymol-0.98.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-0.98.ebuild,v 1.1 2005/05/18 17:56:11 ribosome Exp $
+
+inherit distutils eutils multilib
+
+DESCRIPTION="A Python-extensible molecular graphics system."
+HOMEPAGE="http://pymol.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pymol/${PN}-${PV/./_}-src.tgz"
+
+LICENSE="PSF-2.2"
+IUSE=""
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+DEPEND="dev-lang/python
+ dev-python/pmw
+ dev-python/numeric
+ dev-lang/tk
+ media-libs/libpng
+ sys-libs/zlib
+ media-libs/glut"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Turn off splash screen. Please do make a project contribution
+ # if you are able though.
+ [[ -n "$WANT_NOSPLASH" ]] && epatch ${FILESDIR}/nosplash-gentoo.patch
+}
+
+src_install() {
+ distutils_src_install
+ cd ${S}
+ PYTHONPATH=$(find ${D}/usr/$(get_libdir) -type d -name site-packages) ${python} setup2.py
+
+ local sedexp="s:${D%/}::g"
+ sed -e ${sedexp} pymol.com > pymol
+ exeinto /usr/bin
+ doexe pymol
+ dodoc DEVELOPERS CHANGES
+ #install examples
+ mv examples ${D}/usr/share/doc/${PF}
+}