summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/matio')
-rw-r--r--sci-libs/matio/ChangeLog8
-rw-r--r--sci-libs/matio/files/matio-1.5.0-asneeded.patch11
-rw-r--r--sci-libs/matio/matio-1.5.0.ebuild48
-rw-r--r--sci-libs/matio/metadata.xml3
4 files changed, 69 insertions, 1 deletions
diff --git a/sci-libs/matio/ChangeLog b/sci-libs/matio/ChangeLog
index 2efaaebd867d..91b238920356 100644
--- a/sci-libs/matio/ChangeLog
+++ b/sci-libs/matio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/matio
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/matio/ChangeLog,v 1.1 2012/04/05 20:26:26 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/matio/ChangeLog,v 1.2 2012/04/24 17:50:42 bicatali Exp $
+
+*matio-1.5.0 (24 Apr 2012)
+
+ 24 Apr 2012; Sébastien Fabbro <bicatali@gentoo.org> +matio-1.5.0.ebuild,
+ +files/matio-1.5.0-asneeded.patch, metadata.xml:
+ Version bump
05 Apr 2012; Andrey Grozin <grozin@gentoo.org> +matio-1.3.4.ebuild,
+files/matio-1.3.4-autotools.patch, +metadata.xml:
diff --git a/sci-libs/matio/files/matio-1.5.0-asneeded.patch b/sci-libs/matio/files/matio-1.5.0-asneeded.patch
new file mode 100644
index 000000000000..0f1e462c69f0
--- /dev/null
+++ b/sci-libs/matio/files/matio-1.5.0-asneeded.patch
@@ -0,0 +1,11 @@
+--- matio-1.5.0.orig/src/Makefile.am 2012-04-24 18:14:45.000000000 +0100
++++ matio-1.5.0/src/Makefile.am 2012-04-24 18:18:14.000000000 +0100
+@@ -45,7 +45,7 @@
+ lib_LTLIBRARIES = libmatio.la
+ libmatio_la_SOURCES = snprintf.c endian.c io.c $(ZLIB_SRC) read_data.c \
+ mat5.c mat4.c mat.c matvar_cell.c matvar_struct.c
+-libmatio_la_LIBADD = $(ZLIB_LIBS)
++libmatio_la_LIBADD = $(ZLIB_LIBS) $(HDF5_LIBS)
+
+ if MAT73
+ libmatio_la_SOURCES+= mat73.c
diff --git a/sci-libs/matio/matio-1.5.0.ebuild b/sci-libs/matio/matio-1.5.0.ebuild
new file mode 100644
index 000000000000..f9cc55fa3522
--- /dev/null
+++ b/sci-libs/matio/matio-1.5.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/matio/matio-1.5.0.ebuild,v 1.1 2012/04/24 17:50:42 bicatali Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="Library for reading and writing matlab files"
+HOMEPAGE="http://sourceforge.net/projects/matio/"
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples hdf5 sparse static-libs"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RDEPEND="sys-libs/zlib
+ hdf5? ( sci-libs/hdf5 )"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --enable-shared \
+ $(use_enable hdf5 mat73) \
+ $(use_enable sparse extended-sparse) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+ use doc && emake -C documentation pdf
+}
+
+src_install() {
+ default
+ use doc && dodoc documentation/matio_user_guide.pdf
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins test/test*
+ insinto /usr/share/${PN}
+ doins share/test*
+ fi
+}
diff --git a/sci-libs/matio/metadata.xml b/sci-libs/matio/metadata.xml
index 7e65648fd53e..2d082b20ff6d 100644
--- a/sci-libs/matio/metadata.xml
+++ b/sci-libs/matio/metadata.xml
@@ -6,4 +6,7 @@
matio is an ISO C library (with a limited Fortran 90 interface) for
reading and writing Matlab MAT files.
</longdescription>
+<use>
+ <flag name='sparse'>Extend formats for sparse matrix (not matlab)</flag>
+</use>
</pkgmetadata>