summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/kseg')
-rw-r--r--sci-mathematics/kseg/ChangeLog7
-rw-r--r--sci-mathematics/kseg/kseg-0.403.ebuild12
2 files changed, 12 insertions, 7 deletions
diff --git a/sci-mathematics/kseg/ChangeLog b/sci-mathematics/kseg/ChangeLog
index 2b5fbc200a4d..8729bbf1bfbc 100644
--- a/sci-mathematics/kseg/ChangeLog
+++ b/sci-mathematics/kseg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/kseg
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/kseg/ChangeLog,v 1.5 2007/07/18 02:11:03 cryos Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/kseg/ChangeLog,v 1.6 2008/07/27 22:21:48 carlo Exp $
+
+ 27 Jul 2008; Carsten Lohrke <carlo@gentoo.org> kseg-0.403.ebuild:
+ QA: Get rid of deprecated qt_min_version().
18 Jul 2007; Marcus D. Hanwell <cryos@gentoo.org>
-files/kseg-0.402-gentoo.patch, -kseg-0.402.ebuild, kseg-0.403.ebuild:
diff --git a/sci-mathematics/kseg/kseg-0.403.ebuild b/sci-mathematics/kseg/kseg-0.403.ebuild
index e5ba61e29297..9a889fdc9321 100644
--- a/sci-mathematics/kseg/kseg-0.403.ebuild
+++ b/sci-mathematics/kseg/kseg-0.403.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/kseg/kseg-0.403.ebuild,v 1.4 2007/07/18 02:11:03 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/kseg/kseg-0.403.ebuild,v 1.5 2008/07/27 22:21:48 carlo Exp $
+
+EAPI=1
inherit eutils qt3
@@ -11,20 +13,20 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 ~x86"
IUSE="examples"
-DEPEND="$(qt_min_version 3.3)"
+DEPEND="x11-libs/qt:3"
S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# Fix silly hardcoded help file path and CCFLAGS.
#epatch ${FILESDIR}/${P}-gentoo.patch
sed -i -e "s|KSEG_HELP_DIR|${PF}/help|" main.cpp
}
src_compile() {
- ${QTDIR}/bin/qmake QMAKE=${QTDIR}/bin/qmake || die 'qmake failed.'
+ "${QTDIR}"/bin/qmake QMAKE="${QTDIR}"/bin/qmake || die 'qmake failed.'
emake || die 'emake failed.'
}