summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/yacas/ChangeLog8
-rw-r--r--sci-mathematics/yacas/Manifest6
-rw-r--r--sci-mathematics/yacas/files/digest-yacas-1.0.581
-rw-r--r--sci-mathematics/yacas/yacas-1.0.56.ebuild19
-rw-r--r--sci-mathematics/yacas/yacas-1.0.57.ebuild19
-rw-r--r--sci-mathematics/yacas/yacas-1.0.58.ebuild47
6 files changed, 81 insertions, 19 deletions
diff --git a/sci-mathematics/yacas/ChangeLog b/sci-mathematics/yacas/ChangeLog
index ab2436bf283d..3b66664f72e8 100644
--- a/sci-mathematics/yacas/ChangeLog
+++ b/sci-mathematics/yacas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/yacas
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/ChangeLog,v 1.4 2005/01/14 17:05:53 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/ChangeLog,v 1.5 2005/10/02 02:47:45 ribosome Exp $
+
+*yacas-1.0.58 (02 Oct 2005)
+
+ 02 Oct 2005; Olivier Fisette <ribosome@gentoo.org> yacas-1.0.56.ebuild,
+ yacas-1.0.57.ebuild, +yacas-1.0.58.ebuild:
+ New version. Ebuild clean-ups. Fixed location of help files (bug #106308).
*yacas-1.0.57 (14 Jan 2005)
diff --git a/sci-mathematics/yacas/Manifest b/sci-mathematics/yacas/Manifest
index 19a727275d80..75a513020bc5 100644
--- a/sci-mathematics/yacas/Manifest
+++ b/sci-mathematics/yacas/Manifest
@@ -1,8 +1,10 @@
-MD5 2776d31ce8877df278bdb7ae2924dfac yacas-1.0.57.ebuild 1164
-MD5 20a61dc92ddb7f0745c4bdb15abb999f yacas-1.0.56.ebuild 1337
+MD5 853be5f0d727064005d0cc2afbbeb17e yacas-1.0.57.ebuild 1445
+MD5 1929374e6a06414f2f2a19c327ff9b51 yacas-1.0.56.ebuild 1606
+MD5 b3b69a3fe29a1f8ef8a751620fb2bfac yacas-1.0.58.ebuild 1411
MD5 f6a0d8a4a6012482cdc93c69f3910350 ChangeLog 2452
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 5c748030f6e6f803d4e272ce57a31361 files/digest-yacas-1.0.56 130
MD5 e222e9a7debd7c3e79ee700005276c93 files/digest-yacas-1.0.57 65
+MD5 7a24f28d999fff717cf52796702c816d files/digest-yacas-1.0.58 65
MD5 b49a5413d88ccb8242bc01dedb22afd0 files/opengl-gcc3.4.patch 227
MD5 3edf1638789f8529fb17f44a33907e47 files/1.0.57.patch 1955
diff --git a/sci-mathematics/yacas/files/digest-yacas-1.0.58 b/sci-mathematics/yacas/files/digest-yacas-1.0.58
new file mode 100644
index 000000000000..ac8f19136373
--- /dev/null
+++ b/sci-mathematics/yacas/files/digest-yacas-1.0.58
@@ -0,0 +1 @@
+MD5 fd7fa942789fdac8fa363e555c86cae9 yacas-1.0.58.tar.gz 2089209
diff --git a/sci-mathematics/yacas/yacas-1.0.56.ebuild b/sci-mathematics/yacas/yacas-1.0.56.ebuild
index 96c29b5730b9..d44c00ec1f2a 100644
--- a/sci-mathematics/yacas/yacas-1.0.56.ebuild
+++ b/sci-mathematics/yacas/yacas-1.0.56.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.0.56.ebuild,v 1.2 2005/01/14 09:12:36 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.0.56.ebuild,v 1.3 2005/10/02 02:47:45 ribosome Exp $
inherit eutils
@@ -23,9 +23,9 @@ DEPEND="virtual/libc
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${WORKDIR}/${P}.patch
- epatch ${FILESDIR}/opengl-gcc3.4.patch
+ cd "${S}"
+ epatch "${WORKDIR}"/${P}.patch
+ epatch "${FILESDIR}"/opengl-gcc3.4.patch
}
src_compile() {
@@ -42,11 +42,14 @@ src_install() {
find -name Makefile |xargs sed -i -e "s:datadir = /usr/share:datadir = ${D}/usr/share:"
cd manmake
sed -i -e "s:htmldir = :htmldir = ${D}:" -e "s:psdir = :psdir = ${D}:" Makefile
- cd ${S}
+ cd "${S}"
- DESTDIR=${D} make install-strip || die
+ DESTDIR="${D}" make install-strip || die
dodoc AUTHORS INSTALL NEWS README TODO
- mv ${D}/usr/share/${PN}/documentation ${D}/usr/share/doc/${PF}/html
- rmdir ${D}/usr/include/
+ mv "${D}"/usr/share/${PN}/documentation "${D}"/usr/share/doc/${PF}/html
+ rmdir "${D}"/usr/include/
+ sed -e "s|\":FindFile(\"documentation/ref.html\"):\"|localhost/usr/share/doc/${PF}/html/ref.html|" \
+ -e "s|\":FindFile(\"documentation/books.html\"):\"|localhost/usr/share/doc/${PF}/html/books.html|" \
+ -i "${D}"/usr/share/${PN}/yacasinit.ys || die
}
diff --git a/sci-mathematics/yacas/yacas-1.0.57.ebuild b/sci-mathematics/yacas/yacas-1.0.57.ebuild
index 8405b4783a9f..cb50c2e3e298 100644
--- a/sci-mathematics/yacas/yacas-1.0.57.ebuild
+++ b/sci-mathematics/yacas/yacas-1.0.57.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.0.57.ebuild,v 1.1 2005/01/14 17:05:53 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.0.57.ebuild,v 1.2 2005/10/02 02:47:45 ribosome Exp $
inherit eutils
@@ -16,13 +16,13 @@ KEYWORDS="~x86 ~ppc ~amd64"
DEPEND="virtual/libc
>=sys-apps/sed-4
- glut? ( media-libs/glut )"
-
+ glut? ( media-libs/glut )
+ www-client/lynx"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}.patch
if ! use glut; then
sed -e 's:opengl::g' -i plugins/Makefile.in || die "sed (opengl) failed"
sed -e 's/\(^PLUGINDOCSCHAPTERS.*\)opengl.chapt\(.*\)/\1 \2/' -i \
@@ -39,7 +39,10 @@ src_install() {
make DESTDIR="${D}" install-strip || die
dodoc AUTHORS INSTALL NEWS README TODO
- mv ${D}/usr/share/${PN}/documentation ${D}/usr/share/doc/${PF}/html
- rmdir ${D}/usr/include/
- rm ${D}/usr/share/${PN}/include/win32*
+ mv "${D}"/usr/share/${PN}/documentation "${D}"/usr/share/doc/${PF}/html
+ rmdir "${D}"/usr/include/
+ rm "${D}"/usr/share/${PN}/include/win32*
+ sed -e "s|\":FindFile(\"documentation/ref.html\"):\"|localhost/usr/share/doc/${PF}/html/ref.html|" \
+ -e "s|\":FindFile(\"documentation/books.html\"):\"|localhost/usr/share/doc/${PF}/html/books.html|" \
+ -i "${D}"/usr/share/${PN}/yacasinit.ys || die
}
diff --git a/sci-mathematics/yacas/yacas-1.0.58.ebuild b/sci-mathematics/yacas/yacas-1.0.58.ebuild
new file mode 100644
index 000000000000..66c245f6b71a
--- /dev/null
+++ b/sci-mathematics/yacas/yacas-1.0.58.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.0.58.ebuild,v 1.1 2005/10/02 02:47:45 ribosome Exp $
+
+inherit eutils
+
+IUSE="glut"
+
+DESCRIPTION="very powerful general purpose Computer Algebra System"
+HOMEPAGE="http://yacas.sourceforge.net/"
+SRC_URI="http://${PN}.sourceforge.net/backups/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+DEPEND="virtual/libc
+ >=sys-apps/sed-4
+ glut? ( media-libs/glut )
+ www-client/lynx"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if ! use glut; then
+ sed -e 's:opengl::g' -i plugins/Makefile.in || die "sed (opengl) failed"
+ sed -e 's/\(^PLUGINDOCSCHAPTERS.*\)opengl.chapt\(.*\)/\1 \2/' -i \
+ manmake/Makefile.in || die 'sed (manmake) failed'
+ fi
+}
+
+src_compile() {
+ econf --with-numlib=native || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install-strip || die
+
+ dodoc AUTHORS INSTALL NEWS README TODO
+ mv "${D}"/usr/share/${PN}/documentation "${D}"/usr/share/doc/${PF}/html
+ rmdir "${D}"/usr/include/
+ rm "${D}"/usr/share/${PN}/include/win32*
+ sed -e "s|\":FindFile(\"documentation/ref.html\"):\"|localhost/usr/share/doc/${PF}/html/ref.html|" \
+ -e "s|\":FindFile(\"documentation/books.html\"):\"|localhost/usr/share/doc/${PF}/html/books.html|" \
+ -i "${D}"/usr/share/${PN}/yacasinit.ys || die
+}