summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/attr/attr-2.4.39.ebuild')
-rw-r--r--sys-apps/attr/attr-2.4.39.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sys-apps/attr/attr-2.4.39.ebuild b/sys-apps/attr/attr-2.4.39.ebuild
index b2bb8040389f..41ec79c85c0e 100644
--- a/sys-apps/attr/attr-2.4.39.ebuild
+++ b/sys-apps/attr/attr-2.4.39.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.39.ebuild,v 1.11 2007/12/11 10:18:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.39.ebuild,v 1.12 2008/02/23 03:57:01 vapier Exp $
inherit eutils autotools toolchain-funcs
@@ -23,13 +23,18 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PN}-2.4.39-gettext.patch
+ epatch "${FILESDIR}"/${PN}-2.4.39-linguas.patch #205948
epatch "${FILESDIR}"/${PN}-2.4.24-only-symlink-when-needed.patch
sed -i \
-e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
-e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
include/builddefs.in \
|| die "failed to update builddefs"
+ # libtool will clobber install-sh which is really a custom file
+ mv install-sh acl.install-sh || die
AT_M4DIR="m4" eautoreconf
+ mv acl.install-sh install-sh || die
+ strip-linguas po
}
src_compile() {