summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/iproute2')
-rw-r--r--sys-apps/iproute2/ChangeLog7
-rw-r--r--sys-apps/iproute2/files/iproute2-3.8.0-old-mount-libc.patch38
-rw-r--r--sys-apps/iproute2/iproute2-3.8.0.ebuild3
3 files changed, 46 insertions, 2 deletions
diff --git a/sys-apps/iproute2/ChangeLog b/sys-apps/iproute2/ChangeLog
index e431cf853dc3..c3e63ec24094 100644
--- a/sys-apps/iproute2/ChangeLog
+++ b/sys-apps/iproute2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/iproute2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.223 2013/05/01 06:29:19 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.224 2013/05/04 05:09:02 vapier Exp $
+
+ 04 May 2013; Mike Frysinger <vapier@gentoo.org>
+ +files/iproute2-3.8.0-old-mount-libc.patch, iproute2-3.8.0.ebuild:
+ Fix build with older C libs and missing defines in mount.h #468120 by Agostino
+ Sarubbo.
*iproute2-3.9.0 (01 May 2013)
diff --git a/sys-apps/iproute2/files/iproute2-3.8.0-old-mount-libc.patch b/sys-apps/iproute2/files/iproute2-3.8.0-old-mount-libc.patch
new file mode 100644
index 000000000000..96280e042453
--- /dev/null
+++ b/sys-apps/iproute2/files/iproute2-3.8.0-old-mount-libc.patch
@@ -0,0 +1,38 @@
+From 03fdb011dd661315a83998af8af779d8f089e3fe Mon Sep 17 00:00:00 2001
+From: Stephen Hemminger <stephen@networkplumber.org>
+Date: Wed, 17 Apr 2013 13:33:26 -0700
+Subject: [PATCH] ipnetns: fix build on older systems
+
+Debian Squeeze has out of date <sys/mount.h> without the required flags.
+---
+ ip/ipnetns.c | 14 ++++++++++++++
+ 1 file changed, 14 insertions(+)
+
+diff --git a/ip/ipnetns.c b/ip/ipnetns.c
+index b047b97..c9bc20a 100644
+--- a/ip/ipnetns.c
++++ b/ip/ipnetns.c
+@@ -29,6 +29,20 @@
+ #define MNT_DETACH 0x00000002 /* Just detach from the tree */
+ #endif /* MNT_DETACH */
+
++/* sys/mount.h may be out too old to have these */
++#ifndef MS_REC
++#define MS_REC 16384
++#endif
++
++#ifndef MS_SLAVE
++#define MS_SLAVE (1 << 19)
++#endif
++
++#ifndef MS_SHARED
++#define MS_SHARED (1 << 20)
++#endif
++
++
+ #ifndef HAVE_SETNS
+ static int setns(int fd, int nstype)
+ {
+--
+1.8.2.1
+
diff --git a/sys-apps/iproute2/iproute2-3.8.0.ebuild b/sys-apps/iproute2/iproute2-3.8.0.ebuild
index 84ff71535b3c..a363a6b2c110 100644
--- a/sys-apps/iproute2/iproute2-3.8.0.ebuild
+++ b/sys-apps/iproute2/iproute2-3.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-3.8.0.ebuild,v 1.13 2013/04/29 21:06:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-3.8.0.ebuild,v 1.14 2013/05/04 05:09:02 vapier Exp $
EAPI="4"
@@ -35,6 +35,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${PN}-3.1.0-mtu.patch #291907
+ epatch "${FILESDIR}"/${P}-old-mount-libc.patch #468120
use ipv6 || epatch "${FILESDIR}"/${PN}-3.1.0-no-ipv6.patch #326849
sed -i \