summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/mbuffer/mbuffer-20100526.ebuild')
-rw-r--r--sys-block/mbuffer/mbuffer-20100526.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-block/mbuffer/mbuffer-20100526.ebuild b/sys-block/mbuffer/mbuffer-20100526.ebuild
new file mode 100644
index 000000000000..0b692a2aab03
--- /dev/null
+++ b/sys-block/mbuffer/mbuffer-20100526.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/mbuffer/mbuffer-20100526.ebuild,v 1.1 2010/06/04 18:26:59 vapier Exp $
+
+DESCRIPTION="M(easuring)buffer is a replacement for buffer with additional functionality"
+HOMEPAGE="http://www.maier-komor.de/mbuffer.html"
+SRC_URI="http://www.maier-komor.de/software/mbuffer/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug ssl"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:/bin/ksh:/bin/sh:' Makefile.in #258359
+ ln -s "${DISTDIR}"/${P}.tgz test.tar #258881
+}
+
+src_compile() {
+ econf \
+ $(use_enable ssl md5) \
+ $(use_enable debug) \
+ || die "econf failed"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ dodoc AUTHORS INSTALL NEWS README ChangeLog
+}