summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/sparse')
-rw-r--r--sys-devel/sparse/files/sparse-0.3-makefile-fix.patch34
-rw-r--r--sys-devel/sparse/files/sparse-0.4-makefile-fix.patch11
-rw-r--r--sys-devel/sparse/sparse-0.3-r1.ebuild32
-rw-r--r--sys-devel/sparse/sparse-0.4.ebuild32
4 files changed, 0 insertions, 109 deletions
diff --git a/sys-devel/sparse/files/sparse-0.3-makefile-fix.patch b/sys-devel/sparse/files/sparse-0.3-makefile-fix.patch
deleted file mode 100644
index a89316b54f11..000000000000
--- a/sys-devel/sparse/files/sparse-0.3-makefile-fix.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- sparse-0.3/Makefile
-+++ sparse-0.3/Makefile
-@@ -16,9 +16,9 @@
- CFLAGS += -DDEBUG
-
- DESTDIR=
--PREFIX=$(HOME)
--BINDIR=$(PREFIX)/bin
--LIBDIR=$(PREFIX)/lib
--INCLUDEDIR=$(PREFIX)/include
-+PREFIX=
-+BINDIR=$(PREFIX)/usr/bin
-+LIBDIR=$(PREFIX)/usr/lib
-+INCLUDEDIR=$(PREFIX)/usr/include
- PKGCONFIGDIR=$(LIBDIR)/pkgconfig
-
-@@ -38,7 +38,7 @@
- LIB_FILE= libsparse.a
- SLIB_FILE= libsparse.so
-
--LIBS=$(LIB_FILE)
-+LIBS=$(SLIB_FILE)
-
- all: $(PROGRAMS) sparse.pc
-
-@@ -101,7 +101,7 @@
- $(AR) rcs $@ $(LIB_OBJS)
-
- $(SLIB_FILE): $(LIB_OBJS)
-- $(CC) -shared -o $@ $(LIB_OBJS)
-+ $(CC) $(LDFLAGS) -Wl,-soname,$@ -shared -o $@ $(LIB_OBJS)
-
- evaluate.o: $(LIB_H)
- expression.o: $(LIB_H)
diff --git a/sys-devel/sparse/files/sparse-0.4-makefile-fix.patch b/sys-devel/sparse/files/sparse-0.4-makefile-fix.patch
deleted file mode 100644
index 5af1467b2c78..000000000000
--- a/sys-devel/sparse/files/sparse-0.4-makefile-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- sparse-0.4/Makefile
-+++ sparse-0.4/Makefile
-@@ -81,7 +81,7 @@
- $(QUIET_INST_SH)install -v $$f $(DESTDIR)$(BINDIR)/$$f || exit 1; \
- done
- $(Q)for f in $(INST_MAN1); do \
-- $(QUIET_INST_SH)install -v $$f $(DESTDIR)$(MAN1DIR)/$$f || exit 1; \
-+ $(QUIET_INST_SH)install -v $$f -m 0644 $(DESTDIR)$(MAN1DIR)/$$f || exit 1; \
- done
- $(Q)for f in $(LIBS); do \
- $(QUIET_INST_SH)install -m 644 -v $$f $(DESTDIR)$(LIBDIR)/$$f || exit 1; \
diff --git a/sys-devel/sparse/sparse-0.3-r1.ebuild b/sys-devel/sparse/sparse-0.3-r1.ebuild
deleted file mode 100644
index f88fd65569ba..000000000000
--- a/sys-devel/sparse/sparse-0.3-r1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-0.3-r1.ebuild,v 1.8 2008/04/12 18:31:52 vapier Exp $
-
-inherit eutils multilib
-
-DESCRIPTION="C semantic parser"
-HOMEPAGE="http://kernel.org/pub/linux/kernel/people/josh/sparse/"
-SRC_URI="http://kernel.org/pub/linux/kernel/people/josh/sparse/dist/${P}.tar.gz"
-
-LICENSE="OSL-1.1"
-SLOT="0"
-KEYWORDS="amd64 arm hppa ia64 ppc s390 sh x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${WORKDIR}"
- epatch "${FILESDIR}"/${P}-makefile-fix.patch
-}
-
-src_compile() {
- emake CFLAGS="${CFLAGS} -fpic" LDFLAGS="${LDFLAGS}" || die
-}
-
-src_install() {
- emake DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" install || die "make install failed"
- dodoc FAQ README
-}
diff --git a/sys-devel/sparse/sparse-0.4.ebuild b/sys-devel/sparse/sparse-0.4.ebuild
deleted file mode 100644
index 96c9e6763c28..000000000000
--- a/sys-devel/sparse/sparse-0.4.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-0.4.ebuild,v 1.8 2007/12/10 04:00:36 lu_zero Exp $
-
-inherit eutils multilib
-
-DESCRIPTION="C semantic parser"
-HOMEPAGE="http://kernel.org/pub/linux/kernel/people/josh/sparse/"
-SRC_URI="http://kernel.org/pub/linux/kernel/people/josh/sparse/dist/${P}.tar.gz"
-
-LICENSE="OSL-1.1"
-SLOT="0"
-KEYWORDS="amd64 arm hppa ia64 ppc ppc64 s390 sh x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e '/^PREFIX=/s:=.*:=/usr:' \
- -e "/^LIBDIR=/s:/lib:/$(get_libdir):" \
- Makefile || die
- epatch "${FILESDIR}"/${P}-makefile-fix.patch
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc FAQ README
-}