summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/xfsdump')
-rw-r--r--sys-fs/xfsdump/ChangeLog8
-rw-r--r--sys-fs/xfsdump/files/digest-xfsdump-2.2.423
-rw-r--r--sys-fs/xfsdump/files/xfsdump-2.2.42-Makefile-deps.patch28
-rw-r--r--sys-fs/xfsdump/xfsdump-2.2.42.ebuild50
4 files changed, 88 insertions, 1 deletions
diff --git a/sys-fs/xfsdump/ChangeLog b/sys-fs/xfsdump/ChangeLog
index b53b8ab9ecca..5a1611cefc7d 100644
--- a/sys-fs/xfsdump/ChangeLog
+++ b/sys-fs/xfsdump/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/xfsdump
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.39 2006/09/05 05:16:52 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.40 2006/09/27 06:10:48 vapier Exp $
+
+*xfsdump-2.2.42 (27 Sep 2006)
+
+ 27 Sep 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/xfsdump-2.2.42-Makefile-deps.patch, +xfsdump-2.2.42.ebuild:
+ Version bump.
05 Sep 2006; Joshua Kinard <kumba@gentoo.org> xfsdump-2.2.33-r1.ebuild:
Marked stable on mips.
diff --git a/sys-fs/xfsdump/files/digest-xfsdump-2.2.42 b/sys-fs/xfsdump/files/digest-xfsdump-2.2.42
new file mode 100644
index 000000000000..e39f6e37132b
--- /dev/null
+++ b/sys-fs/xfsdump/files/digest-xfsdump-2.2.42
@@ -0,0 +1,3 @@
+MD5 4e113a39b07723bbb140d2e5c5389cfe xfsdump_2.2.42-1.tar.gz 554462
+RMD160 1046042444c97a66fddcd5d5e6e03891d590f418 xfsdump_2.2.42-1.tar.gz 554462
+SHA256 3840da1ff4d3ef5bef350bff3199fde2818153a38779bc96b9714c0e07bed828 xfsdump_2.2.42-1.tar.gz 554462
diff --git a/sys-fs/xfsdump/files/xfsdump-2.2.42-Makefile-deps.patch b/sys-fs/xfsdump/files/xfsdump-2.2.42-Makefile-deps.patch
new file mode 100644
index 000000000000..6ab15d7490ca
--- /dev/null
+++ b/sys-fs/xfsdump/files/xfsdump-2.2.42-Makefile-deps.patch
@@ -0,0 +1,28 @@
+Fix parallel build
+
+http://bugs.gentoo.org/136373
+
+--- xfsdump-2.2.33/dump/Makefile
++++ xfsdump-2.2.33/dump/Makefile
+@@ -106,3 +106,5 @@
+
+ $(INVINCL) $(INVCOMMON):
+ $(RM) $@; $(LN_S) ../inventory/$@ $@
++
++$(LOCALS): $(LINKS)
+--- xfsdump-2.2.33/invutil/Makefile
++++ xfsdump-2.2.33/invutil/Makefile
+@@ -70,3 +70,5 @@
+
+ $(INVINCL) $(INVCOMMON):
+ $(RM) $@; $(LN_S) ../inventory/$@ $@
++
++$(LOCALS): $(LINKS)
+--- xfsdump-2.2.33/restore/Makefile
++++ xfsdump-2.2.33/restore/Makefile
+@@ -116,3 +116,5 @@
+
+ $(INVINCL) $(INVCOMMON):
+ $(RM) $@; $(LN_S) ../inventory/$@ $@
++
++$(LOCALS): $(LINKS)
diff --git a/sys-fs/xfsdump/xfsdump-2.2.42.ebuild b/sys-fs/xfsdump/xfsdump-2.2.42.ebuild
new file mode 100644
index 000000000000..a8acce2cf259
--- /dev/null
+++ b/sys-fs/xfsdump/xfsdump-2.2.42.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-2.2.42.ebuild,v 1.1 2006/09/27 06:10:48 vapier Exp $
+
+inherit eutils autotools
+
+MY_P="${PN}_${PV}-1"
+DESCRIPTION="xfs dump/restore utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86"
+IUSE=""
+
+DEPEND="sys-fs/e2fsprogs
+ sys-fs/xfsprogs
+ sys-apps/dmapi
+ >=sys-apps/attr-2.4.19"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.2.33-no-compress-docs.patch
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ -e '/^GCFLAGS/s:-O1::' \
+ include/builddefs.in \
+ || die
+ epatch "${FILESDIR}"/${PN}-2.2.42-Makefile-deps.patch
+ eautoconf
+}
+
+src_compile() {
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ --libdir=/$(get_libdir) \
+ --libexecdir=/usr/$(get_libdir) \
+ --sbindir=/sbin \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DIST_ROOT="${D}" install || die
+ prepalldocs
+}