summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/zfs-kmod')
-rw-r--r--sys-fs/zfs-kmod/ChangeLog7
-rw-r--r--sys-fs/zfs-kmod/zfs-kmod-0.6.3.ebuild19
-rw-r--r--sys-fs/zfs-kmod/zfs-kmod-9999.ebuild19
3 files changed, 33 insertions, 12 deletions
diff --git a/sys-fs/zfs-kmod/ChangeLog b/sys-fs/zfs-kmod/ChangeLog
index 9448b255a34a..89e7f74bcd8b 100644
--- a/sys-fs/zfs-kmod/ChangeLog
+++ b/sys-fs/zfs-kmod/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/zfs-kmod
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-kmod/ChangeLog,v 1.51 2014/08/07 18:23:45 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-kmod/ChangeLog,v 1.52 2014/09/05 18:23:36 ryao Exp $
+
+ 05 Sep 2014; Richard Yao <ryao@gentoo.org> zfs-kmod-0.6.3.ebuild,
+ zfs-kmod-9999.ebuild:
+ Add preliminary ebuild changes for Gentoo Prefix support; Provide message to
+ die if updating META fails; Sync 0.6.3 and 9999 ebuilds.
07 Aug 2014; Richard Yao <ryao@gentoo.org> zfs-kmod-0.6.3.ebuild:
No code changes are needed to support Linux 3.16. I modifying the ebuild to
diff --git a/sys-fs/zfs-kmod/zfs-kmod-0.6.3.ebuild b/sys-fs/zfs-kmod/zfs-kmod-0.6.3.ebuild
index cce3053a4795..2a376d683d20 100644
--- a/sys-fs/zfs-kmod/zfs-kmod-0.6.3.ebuild
+++ b/sys-fs/zfs-kmod/zfs-kmod-0.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-kmod/zfs-kmod-0.6.3.ebuild,v 1.2 2014/08/07 18:23:45 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-kmod/zfs-kmod-0.6.3.ebuild,v 1.3 2014/09/05 18:23:36 ryao Exp $
EAPI="4"
@@ -8,12 +8,12 @@ AT_M4DIR="config"
AUTOTOOLS_AUTORECONF="1"
AUTOTOOLS_IN_SOURCE_BUILD="1"
-inherit bash-completion-r1 flag-o-matic linux-info linux-mod toolchain-funcs autotools-utils
+inherit flag-o-matic linux-info linux-mod toolchain-funcs autotools-utils
if [ ${PV} == "9999" ] ; then
inherit git-2
MY_PV=9999
- EGIT_REPO_URI="git://github.com/zfsonlinux/zfs.git"
+ EGIT_REPO_URI="https://github.com/zfsonlinux/zfs.git"
else
inherit eutils versionator
MY_PV=$(replace_version_separator 3 '-')
@@ -55,6 +55,7 @@ pkg_setup() {
use debug && CONFIG_CHECK="${CONFIG_CHECK}
FRAME_POINTER
DEBUG_INFO
+ !DEBUG_INFO_REDUCED
"
use rootfs && \
@@ -76,7 +77,8 @@ src_prepare() {
use debug || sed -e 's/^subdir-m += zpios$//' -i "${S}/module/Makefile.in"
# Set module revision number
- sed -i "s/\(Release:\)\(.*\)1/\1\2${PR}-gentoo/" "${S}/META" || die
+ [ ${PV} != "9999" ] && \
+ { sed -i "s/\(Release:\)\(.*\)1/\1\2${PR}-gentoo/" "${S}/META" || die "Could not set Gentoo release"; }
autotools-utils_src_prepare
}
@@ -86,7 +88,7 @@ src_configure() {
filter-ldflags -Wl,*
set_arch_to_kernel
- local myeconfargs=(
+ local myeconfargs=(${myeconfargs}
--bindir="${EPREFIX}/bin"
--sbindir="${EPREFIX}/sbin"
--with-config=kernel
@@ -94,11 +96,16 @@ src_configure() {
--with-linux-obj="${KV_OUT_DIR}"
$(use_enable debug)
)
+
+ SPL_PATH=$(basename $(echo "${EROOT}usr/src/spl-"*)) \
+ myeconfargs="${myeconfargs} --with-spl=${EROOT}usr/src/${SPL_PATH} \
+ --with-spl-obj=${EROOT}usr/src/${SPL_PATH}/${KV_FULL}"
+
autotools-utils_src_configure
}
src_install() {
- autotools-utils_src_install
+ autotools-utils_src_install INSTALL_MOD_PATH=${INSTALL_MOD_PATH:-$EROOT}
dodoc AUTHORS COPYRIGHT DISCLAIMER README.markdown
}
diff --git a/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild b/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
index fe9291daa170..750427e9606d 100644
--- a/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
+++ b/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild,v 1.24 2014/07/09 01:29:39 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild,v 1.25 2014/09/05 18:23:36 ryao Exp $
EAPI="4"
@@ -8,7 +8,7 @@ AT_M4DIR="config"
AUTOTOOLS_AUTORECONF="1"
AUTOTOOLS_IN_SOURCE_BUILD="1"
-inherit bash-completion-r1 flag-o-matic linux-info linux-mod toolchain-funcs autotools-utils
+inherit flag-o-matic linux-info linux-mod toolchain-funcs autotools-utils
if [ ${PV} == "9999" ] ; then
inherit git-2
@@ -67,7 +67,7 @@ pkg_setup() {
kernel_is ge 2 6 26 || die "Linux 2.6.26 or newer required"
[ ${PV} != "9999" ] && \
- { kernel_is le 3 15 || die "Linux 3.15 is the latest supported version."; }
+ { kernel_is le 3 16 || die "Linux 3.16 is the latest supported version."; }
check_extra_config
}
@@ -76,6 +76,10 @@ src_prepare() {
# Remove GPLv2-licensed ZPIOS unless we are debugging
use debug || sed -e 's/^subdir-m += zpios$//' -i "${S}/module/Makefile.in"
+ # Set module revision number
+ [ ${PV} != "9999" ] && \
+ { sed -i "s/\(Release:\)\(.*\)1/\1\2${PR}-gentoo/" "${S}/META" || die "Could not set Gentoo release"; }
+
autotools-utils_src_prepare
}
@@ -84,7 +88,7 @@ src_configure() {
filter-ldflags -Wl,*
set_arch_to_kernel
- local myeconfargs=(
+ local myeconfargs=(${myeconfargs}
--bindir="${EPREFIX}/bin"
--sbindir="${EPREFIX}/sbin"
--with-config=kernel
@@ -92,11 +96,16 @@ src_configure() {
--with-linux-obj="${KV_OUT_DIR}"
$(use_enable debug)
)
+
+ SPL_PATH=$(basename $(echo "${EROOT}usr/src/spl-"*)) \
+ myeconfargs="${myeconfargs} --with-spl=${EROOT}usr/src/${SPL_PATH} \
+ --with-spl-obj=${EROOT}usr/src/${SPL_PATH}/${KV_FULL}"
+
autotools-utils_src_configure
}
src_install() {
- autotools-utils_src_install
+ autotools-utils_src_install INSTALL_MOD_PATH=${INSTALL_MOD_PATH:-$EROOT}
dodoc AUTHORS COPYRIGHT DISCLAIMER README.markdown
}